summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-07-23 23:49:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-07-26 11:20:52 +0200
commit2b76f13507bfb4d527695a7e0cfd755295432bc0 (patch)
tree36ce7eca70a5a48037d292d669dfc776c1fbe45c /gnu/packages/linux.scm
parentaf7aaaebab7b7ad584b05c2350584aa980a4bd61 (diff)
gnu: Add haveged.
* gnu/packages/linux.scm (haveged): New variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a2f6ac5cce..001908f899 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2791,3 +2791,33 @@ from that to the system kernel's @file{/dev/random} machinery.")
Linux kernel to retrieve and control processor features related to power saving,
such as frequency and voltage scaling.")
(license license:gpl2)))
+
+(define-public haveged
+ (package
+ (name "haveged")
+ (version "1.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.issihosts.com/haveged/haveged-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "059pxlfd4l5dqhd6r3lynzfz4wby2f17294fy17pi9j2jpnn68ww"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.issihosts.com/haveged")
+ (synopsis "Entropy source for the Linux random number generator")
+ (description
+ "haveged generates an unpredictable stream of random numbers for use by
+Linux's @file{/dev/random} and @file{/dev/urandom} devices. The kernel's
+standard mechanisms for filling the entropy pool may not be sufficient for
+systems with high needs or limited user interaction, such as headless servers.
+@command{haveged} runs as a privileged daemon, harvesting randomness from the
+indirect effects of hardware events on hidden processor state using the HArdware
+Volatile Entropy Gathering and Expansion (HAVEGE) algorithm. It tunes itself to
+its environment and provides the same built-in test suite for the output stream
+as used on certified hardware security devices.")
+ (license (list (license:non-copyleft "file://nist/mconf.h")
+ (license:non-copyleft "file://nist/packtest.c")
+ license:public-domain ; nist/dfft.c
+ license:gpl3+)))) ; everything else