summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-21 13:41:18 -0400
committerMark H Weaver <mhw@netris.org>2018-05-21 13:41:18 -0400
commitab9da9ec66a0631dfb97f059f9c8693ad8000e6d (patch)
treec1100052bba4cf22ff30feb34f98ef09cdb5e1fd /gnu/packages/linux.scm
parent0661758e133c0384d20043d3526b5ebc794e1f04 (diff)
parent4699ffa383ea50442fbe659f687cb5652ab5a557 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 78c696261e..e922b6a5f8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -670,14 +670,14 @@ by Robert Shea and Robert Anton Wilson.")
(define-public procps
(package
(name "procps")
- (version "3.3.12")
+ (version "3.3.14")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/procps-ng/Production/"
"procps-ng-" version ".tar.xz"))
(sha256
(base32
- "1m57w6jmry84njd5sgk5afycbglql0al80grx027kwqqcfw5mmkf"))))
+ "0v3j6rkzzscqds37i105cxx3q4dk04rsgpqfd5p7hzcvk59h5njy"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
@@ -686,15 +686,6 @@ by Robert Shea and Robert Anton Wilson.")
(srfi srfi-26))
#:phases
(modify-phases %standard-phases
- (add-before 'check 'disable-strtod-test
- (lambda _
- ;; Disable the 'strtod' test, which fails on 32-bit systems.
- ;; This is what upstream does:
- ;; <https://gitlab.com/procps-ng/procps/commit/100afbc1491be388f1429021ff65d969f4b1e08f>.
- (substitute* "Makefile"
- (("^(TESTS|check_PROGRAMS) = .*$" all)
- (string-append "# " all "\n")))
- #t))
(add-after
'install 'post-install
;; Remove commands and man pages redudant with