summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 02:16:06 -0400
committerMark H Weaver <mhw@netris.org>2018-04-12 04:01:55 -0400
commit2ee42f7e32045bddd465f230061269ebefe8489b (patch)
treefcc219885900b6d1bd4fcb33f858e087cc5b42c0 /gnu/packages/linux.scm
parent90a54e367456dd02385d223658c6e0e53a033c6a (diff)
gnu: freefall: Return #t from all phases.
* gnu/packages/linux.scm (freefall)[arguments]: Return #t from all phase procedures.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 82e4552194..7efe7faad9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3292,14 +3292,16 @@ disks and SD cards. This package provides the userland utilities.")
'(#:phases (modify-phases %standard-phases
(add-after 'unpack 'enter-subdirectory
(lambda _
- (chdir "tools/laptop/freefall")))
+ (chdir "tools/laptop/freefall")
+ #t))
(delete 'configure)
(add-before 'build 'increase-timeout
(lambda _
;; The default of 2 seconds is too low: it assumes an
;; open lid and AC power without actually checking.
(substitute* "freefall.c"
- (("alarm\\(2\\)") "alarm(5)")))))
+ (("alarm\\(2\\)") "alarm(5)"))
+ #t)))
#:make-flags (list (string-append "PREFIX="
(assoc-ref %outputs "out")))
#:tests? #f)) ;no tests