summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 02:13:57 -0400
committerMark H Weaver <mhw@netris.org>2018-04-12 04:01:53 -0400
commit90a54e367456dd02385d223658c6e0e53a033c6a (patch)
tree955ec46da526020a25a29b269deeec8295b9efa4 /gnu/packages/linux.scm
parentb132ad3a6314b29aca3a149089f1341f91a0f179 (diff)
gnu: gpm: Use invoke.
* gnu/packages/linux.scm (gpm)[arguments]: Use invoke and remove vestigial result code plumbing.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b5201a3b74..82e4552194 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3133,10 +3133,9 @@ write access to exFAT devices.")
;; need to bootstrap things ourselves.
(substitute* "autogen.sh"
(("/bin/sh") (which "sh")))
- (and (zero? (system* "./autogen.sh"))
- (begin
- (patch-makefile-SHELL "Makefile.include.in")
- #t)))))
+ (invoke "./autogen.sh")
+ (patch-makefile-SHELL "Makefile.include.in")
+ #t)))
;; Make sure programs find libgpm.so.
#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="