summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-10-17 13:57:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-10-17 14:07:59 +0200
commit018567adb7b2d31d0bd457983b755ec3063d08c6 (patch)
tree268bb9465f3d30f182b1d80e84ca17a11a07ae5c /gnu/packages/linux.scm
parent2fb94a505b2b8e40c0d2691eb33d734f2b5e4c91 (diff)
gnu: singularity: Do not override PATH.
* gnu/packages/linux.scm (singularity)[arguments]: Prepend coreutils, but don't make it impossible to pick up other tools.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3c34919766..6cd9540da3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5239,9 +5239,11 @@ thanks to the use of namespaces.")
(add-after 'install 'set-PATH
(lambda _
;; Have the 'singularity' and 'run-singularity' self-sufficient.
+ ;; But don't override PATH, so that other tools like zcat and
+ ;; tar can still be found if they are available.
(let ((coreutils #$(this-package-input "coreutils")))
(wrap-program (string-append #$output "/bin/singularity")
- `("PATH" ":" = (,(string-append coreutils "/bin"))))
+ `("PATH" prefix (,(string-append coreutils "/bin"))))
(substitute* (string-append #$output "/bin/run-singularity")
(("/usr/bin/env singularity")
(string-append (which "env") " "