summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-01-14 03:01:37 +0100
committerLeo Famulari <leo@famulari.name>2024-01-22 13:24:20 -0500
commit10a193596368443f441077525ebbddf787d91e4b (patch)
treebf8c432eb846881294e6ae254a0dd8ec71a26c5e /gnu/packages/linux.scm
parent29c26a8d308286cf378ce9cfa3d73e3d1454263d (diff)
gnu: Remove linux-libre 4.14.
* gnu/packages/linux.scm (linux-libre-4.14-version, linux-libre-4.14-gnu-revision, deblob-scripts-4.14, linux-libre-4.14-pristine-source, linux-libre-4.14-source, linux-libre-headers-4.14, linux-libre-4.14, linux-libre-arm-generic-4.14, linux-libre-arm-omap2plus-4.14): Remove variables. * gnu/packages/aux-files/linux-libre/4.14-arm.conf, gnu/packages/aux-files/linux-libre/4.14-i686.conf, gnu/packages/aux-files/linux-libre/4.14-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove aforementioned .conf files. * gnu/tests/base.scm (%test-linux-libre-4.14): Remove variable. Change-Id: I40393b5f46b989848d569c929f1d9c986736553e
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm48
1 files changed, 0 insertions, 48 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8f7dae94fb..ede1bbfce8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -604,21 +604,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-4.19)))
-(define-public linux-libre-4.14-version "4.14.336")
-(define-public linux-libre-4.14-gnu-revision "gnu1")
-(define deblob-scripts-4.14
- (linux-libre-deblob-scripts
- linux-libre-4.14-version
- linux-libre-4.14-gnu-revision
- (base32 "1vbgykwzf7j0yjqcwn747cfhwj0rgw3s9h627q94wb9a19x9p0fr")
- (base32 "1ir96bbhw77xw6lmsnh42gi130nnzjklpgfyd46pxmqckrpydcvx")))
-(define-public linux-libre-4.14-pristine-source
- (let ((version linux-libre-4.14-version)
- (hash (base32 "075nawgvln7ds32cmgg7042qfsf85nzizhc1h0rp8s8wjyvzs808")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-4.14)))
-
(define %boot-logo-patch
;; Linux-Libre boot logo featuring Freedo and a gnu.
(origin
@@ -689,10 +674,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch)))
-(define-public linux-libre-4.14-source
- (source-with-patches linux-libre-4.14-pristine-source
- (list %boot-logo-patch)))
-
;;;
;;; Kernel headers.
@@ -806,11 +787,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
linux-libre-4.19-gnu-revision
linux-libre-4.19-source))
-(define-public linux-libre-headers-4.14
- (make-linux-libre-headers* linux-libre-4.14-version
- linux-libre-4.14-gnu-revision
- linux-libre-4.14-source))
-
;; The following package is used in the early bootstrap, and thus must be kept
;; stable and with minimal build requirements.
(define-public linux-libre-headers-5.15.49
@@ -1182,14 +1158,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
"aarch64-linux" "powerpc64le-linux")
#:configuration-file kernel-config))
-(define-public linux-libre-4.14
- (make-linux-libre* linux-libre-4.14-version
- linux-libre-4.14-gnu-revision
- linux-libre-4.14-source
- '("x86_64-linux" "i686-linux" "armhf-linux"
- "powerpc64le-linux")
- #:configuration-file kernel-config))
-
;; Linux-Libre-LTS points to the *newest* released long-term support version of
;; Linux-Libre.
;; Reference: <https://www.kernel.org/category/releases.html>
@@ -1252,14 +1220,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
#:defconfig "multi_v7_defconfig"
#:extra-version "arm-generic"))
-(define-public linux-libre-arm-generic-4.14
- (make-linux-libre* linux-libre-4.14-version
- linux-libre-4.14-gnu-revision
- linux-libre-4.14-source
- '("armhf-linux")
- #:defconfig "multi_v7_defconfig"
- #:extra-version "arm-generic"))
-
(define-public linux-libre-arm-omap2plus
(make-linux-libre* linux-libre-version
linux-libre-gnu-revision
@@ -1276,14 +1236,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
#:defconfig "omap2plus_defconfig"
#:extra-version "arm-omap2plus"))
-(define-public linux-libre-arm-omap2plus-4.14
- (make-linux-libre* linux-libre-4.14-version
- linux-libre-4.14-gnu-revision
- linux-libre-4.14-source
- '("armhf-linux")
- #:defconfig "omap2plus_defconfig"
- #:extra-version "arm-omap2plus"))
-
(define-public linux-libre-arm64-generic
(make-linux-libre* linux-libre-version
linux-libre-gnu-revision