summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-30 02:00:00 +0200
commit2c7f12a6cb3f8a6646098ef8985c0f6061ccd3fc (patch)
treeccf9d30bedd221229f90a4dad2378aa503b11281 /gnu/packages/linux.scm
parent85736a545d142fbab6a5c15634d1e22adf57df58 (diff)
gnu: Add libtracefs.
* gnu/packages/linux.scm (libtracefs): New public variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3aec03a3ec..595866699e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9975,6 +9975,46 @@ formats.")
(license (list license:gpl2
license:lgpl2.1))))
+(define-public libtracefs
+ (package
+ (name "libtracefs")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0v896n3q0df0nxx5drbwyaqhrqiyxl06rvrdw3gp2r37awa9g1zb"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ (substitute* (list "Makefile" "scripts/utils.mk")
+ (("/bin/(pwd)" _ command) command))))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no test suite
+ #:make-flags
+ #~(list
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "pkgconfig_dir=" #$output "/lib/pkgconfig")
+ (string-append "prefix=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (native-inputs (list pkg-config))
+ (inputs (list libtraceevent))
+ (home-page "https://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git/")
+ (synopsis "Linux kernel trace file system library")
+ (description
+ "This library provides APIs to access the Linux kernel's trace file
+system.")
+ (license (list license:gpl2
+ license:lgpl2.1))))
+
(define-public libtree
(package
(name "libtree")