summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-03-15 12:40:53 -0400
committerMark H Weaver <mhw@netris.org>2016-03-15 12:40:53 -0400
commita3b84f70d8bc992a0fc38cabdf12d48ff5e10e15 (patch)
treeba2c4880e3f4ce6509ff219d0fd646493d085e1d /gnu/packages/linux.scm
parent2c9f0b077018d2cac599bd2f466769cd5ffd3adc (diff)
parent20095cc5139666fe67b3ae76b3f46ff85e4956bb (diff)
Merge branch 'master' into security-updates
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm27
1 files changed, 23 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 045936cd9f..ba0453e71f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -220,7 +220,7 @@ for SYSTEM and optionally VARIANT, or #f if there is no such configuration."
(search-path %load-path file)))
(define-public linux-libre
- (let* ((version "4.4.5")
+ (let* ((version "4.5")
(build-phase
'(lambda* (#:key system inputs #:allow-other-keys #:rest args)
;; Apply the neat patch.
@@ -294,7 +294,7 @@ for SYSTEM and optionally VARIANT, or #f if there is no such configuration."
(uri (linux-libre-urls version))
(sha256
(base32
- "19yyw6yssyxr9k5y3whgz2p731mb1pnq3xajpv8g01m13cxs32dd"))))
+ "0km863vwy557flpygkr869yshpjs1v11ni78p8k9p9nm31ai6yn3"))))
(build-system gnu-build-system)
(supported-systems '("x86_64-linux" "i686-linux"))
(native-inputs `(("perl" ,perl)
@@ -303,8 +303,10 @@ for SYSTEM and optionally VARIANT, or #f if there is no such configuration."
("module-init-tools" ,module-init-tools)
("patch/freedo+gnu" ,%boot-logo-patch)
- ,@(let ((conf (kernel-config (or (%current-target-system)
- (%current-system)))))
+ ,@(let ((conf (kernel-config
+ (or (%current-target-system)
+ (%current-system))
+ #:variant (version-major+minor version))))
(if conf
`(("kconfig" ,conf))
'()))))
@@ -326,6 +328,23 @@ It has been modified to remove all non-free binary blobs.")
(license license:gpl2)
(home-page "http://www.gnu.org/software/linux-libre/"))))
+(define-public linux-libre-4.4
+ (package
+ (inherit linux-libre)
+ (version "4.4.5")
+ (source (origin
+ (method url-fetch)
+ (uri (linux-libre-urls version))
+ (sha256
+ (base32
+ "19yyw6yssyxr9k5y3whgz2p731mb1pnq3xajpv8g01m13cxs32dd"))))
+ (native-inputs
+ (let ((conf (kernel-config (or (%current-target-system)
+ (%current-system))
+ #:variant "4.4")))
+ `(,@(alist-delete "kconfig" (package-native-inputs linux-libre))
+ ("kconfig" ,conf))))))
+
(define-public linux-libre-4.1
(package
(inherit linux-libre)