summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-check.scm
diff options
context:
space:
mode:
authorMike Delago <michaeldelago98@gmail.com>2023-07-09 18:31:18 -0400
committerGuillaume Le Vaillant <glv@posteo.net>2023-07-10 09:55:33 +0200
commit126a91888c921179e90090c4c023d6285bfd44a0 (patch)
treeec9279c704e2f933f0541802ed16a41874b5f424 /gnu/packages/lisp-check.scm
parent1c194cd2bb5191f73499ec869952859d711ff225 (diff)
gnu: cl-rove: Update to 0.10.0-1.6a5dfcd.
* gnu/packages/lisp-check.scm (sbcl-rove): Update to 0.10.0-1.6a5dfcd. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-check.scm')
-rw-r--r--gnu/packages/lisp-check.scm45
1 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 1d2e439e9a..4b18f79a44 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -868,29 +868,30 @@ tester module.")
(sbcl-package->ecl-package sbcl-ptester))
(define-public sbcl-rove
- (package
- (name "sbcl-rove")
- (version "0.9.6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/fukamachi/rove")
- (commit "f3695db08203bf26f3b861dc22ac0f4257d3ec21")))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "07ala4l2fncxf540fzxj3h5mhi9i4wqllhj0rqk8m2ljl5zbz89q"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- (list sbcl-bordeaux-threads sbcl-dissect sbcl-trivial-gray-streams))
- (home-page "https://github.com/fukamachi/rove")
- (synopsis
- "Yet another common lisp testing library")
- (description
- "Rove is a unit testing framework for Common Lisp applications.
+ (let ((commit "6a5dfcdced42879a4eff2a529e7e8ce492fadf41")
+ (revision "1"))
+ (package
+ (name "sbcl-rove")
+ (version (git-version "0.10.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fukamachi/rove")
+ (commit commit)))
+ (file-name (git-file-name "cl-rove" version))
+ (sha256
+ (base32
+ "1w99c0795ykhn14pfhyhvfzxzz0k1z1bb846xgz3iv19s0j2vykr"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs (list sbcl-bordeaux-threads
+ sbcl-dissect
+ sbcl-trivial-gray-streams))
+ (home-page "https://github.com/fukamachi/rove")
+ (synopsis "Yet another common lisp testing library")
+ (description
+ "Rove is a unit testing framework for Common Lisp applications.
This is intended to be a successor of Prove.")
- (license license:bsd-3)))
+ (license license:bsd-3))))
(define-public cl-rove
(sbcl-package->cl-source-package sbcl-rove))