summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-check.scm
diff options
context:
space:
mode:
authorcage <cage-dev@twistfold.it>2023-08-05 13:00:07 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-08-08 10:31:10 +0200
commit661cd5772d84eb4c8c4c447bd84b67e8949880e1 (patch)
treead60fdb600676de3346b6a3d5b5310a2f1d1eb51 /gnu/packages/lisp-check.scm
parentbe7f5111ce41532cc954b6dacb145e0e64b2bb4c (diff)
gnu: cl-clunit2: Update to 0.5.2-2.5e28343.
* gnu/packages/lisp-check.scm (sbcl-clunit2): Update to 0.5.2-2.5e28343. [source, home-page]: Switch from Notabug to Codeberg. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-check.scm')
-rw-r--r--gnu/packages/lisp-check.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 6bade26aea..ee045d1387 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2022, 2023 André A. Gomes <andremegafone@gmail.com>
+;;; Copyright © 2023 Cage <cage-dev@twistfold.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -355,26 +356,26 @@ experience.")
(sbcl-package->ecl-package sbcl-clunit))
(define-public sbcl-clunit2
- (let ((commit "5e28343734eb9b7aee39306a614af92c1062d50b")
- (revision "1"))
+ (let ((commit "c3159275a6c5af166e60b592c3b7e22eaa69c048")
+ (revision "2"))
(package
(name "sbcl-clunit2")
- (version (git-version "0.2.4" revision commit))
+ (version (git-version "0.5.2" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://notabug.org/cage/clunit2.git")
+ (url "https://codeberg.org/cage/clunit2.git")
(commit commit)))
- (file-name (git-file-name name version))
+ (file-name (git-file-name "cl-clunit2" version))
(sha256
- (base32 "1ngiapfki6nm8a555mzhb5p7ch79i3w665za5bmb5j7q34fy80vw"))))
+ (base32 "0n92z98dqfik3kfp25nz7yqycx4bpxlqbn69i5skcdnrj2ywmv01"))))
(build-system asdf-build-system/sbcl)
(synopsis "Unit testing framework for Common Lisp")
(description
- "CLUnit is a Common Lisp unit testing framework. It is designed to be
+ "CLUnit2 is a Common Lisp unit testing framework. It is designed to be
easy to use so that you can quickly start testing.")
- (home-page "https://notabug.org/cage/clunit2")
+ (home-page "https://codeberg.org/cage/clunit2")
(license license:expat))))
(define-public cl-clunit2