summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-04-17 11:28:45 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-04-17 11:28:45 +0200
commitb6ffcc4de4be43ed3e380b744bdfc9d87a596749 (patch)
treeb89634219ffb0bd45dcf19330323acc023a2c2e0 /gnu/packages/lisp-xyz.scm
parenta2ed9816c9f2e1243ab65e19c432175843b5542a (diff)
gnu: cl-ana: Fix build.
* gnu/packages/lisp-xyz.scm (sbcl-cl-ana)[arguments]: Use gexp. Update 'fix-paths' phase. Add 'fix-newer-hdf5-compatibility' phase.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm39
1 files changed, 29 insertions, 10 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b02892d5f6..64fb1d6e7a 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10809,16 +10809,35 @@ sacrificing much in the way of power.")
(propagated-inputs
(list gnuplot)) ;; for gnuplot-interface
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "hdf-cffi/src/library.lisp"
- (("libhdf5.so")
- (search-input-file inputs "/lib/libhdf5.so")))
- (substitute* "gsl-cffi/gsl-cffi.lisp"
- (("libgsl.so")
- (search-input-file inputs "/lib/libgsl.so"))))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "hdf-cffi/src/library.lisp"
+ (("libhdf5.so")
+ (search-input-file inputs "/lib/libhdf5.so")))
+ (substitute* (list "gsl-cffi/gsl-cffi.lisp"
+ "spline/spline.lisp")
+ (("libgsl.so")
+ (search-input-file inputs "/lib/libgsl.so")))))
+ (add-after 'fix-paths 'fix-newer-hdf5-compatibility
+ (lambda _
+ (substitute* (list "hdf-cffi/src/h5-grovel.lisp"
+ "hdf-cffi/src/h5a-grovel.lisp"
+ "hdf-cffi/src/h5d-grovel.lisp"
+ "hdf-cffi/src/h5f-grovel.lisp"
+ "hdf-cffi/src/h5g-grovel.lisp"
+ "hdf-cffi/src/h5i-grovel.lisp"
+ "hdf-cffi/src/h5l-grovel.lisp"
+ "hdf-cffi/src/h5o-grovel.lisp"
+ "hdf-cffi/src/h5p-grovel.lisp"
+ "hdf-cffi/src/h5pl-grovel.lisp"
+ "hdf-cffi/src/h5r-grovel.lisp"
+ "hdf-cffi/src/h5s-grovel.lisp"
+ "hdf-cffi/src/h5t-grovel.lisp"
+ "hdf-cffi/src/h5z-grovel.lisp")
+ (("_H5private_H")
+ "H5private_H")))))))
(synopsis "Common Lisp data analysis library")
(description
"CL-ANA is a data analysis library in Common Lisp providing tabular and