summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-09-07 19:49:02 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2022-09-09 13:36:30 +0200
commitc58db9b16febd044aa1657f694234c4304b0b57c (patch)
treeb49c4fc118af21786dd836b51eb1a2b70932d597 /gnu/packages/lisp-xyz.scm
parentcb4c65514778f14439b736ee6dd6211c7dae8e1e (diff)
gnu: Add cl-class-options.
* gnu/packages/lisp-xyz.scm (cl-class-options, ecl-class-options, sbcl-class-options): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f42a5ba9d5..884e808453 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -23667,6 +23667,37 @@ model, thereby greatly simplifying the definition of class mixins.")
(define-public ecl-compatible-metaclasses
(sbcl-package->ecl-package sbcl-compatible-metaclasses))
+(define-public sbcl-class-options
+ (package
+ (name "sbcl-class-options")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Hexstream/class-options")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "cl-class-options" version))
+ (sha256
+ (base32 "1dkgr1vbrsra44jznzz2bvdf8nlpdrrkjcqrfs8aa7axksda3bqk"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-enhanced-boolean sbcl-parachute))
+ (inputs
+ (list sbcl-closer-mop sbcl-enhanced-find-class))
+ (home-page "https://www.hexstreamsoft.com/libraries/class-options/")
+ (synopsis "Accessing defining class and its options during modification")
+ (description
+ "This package provides easy access to the defining class and its options
+during initialization or reinitialization of its subcomponents.")
+ (license license:unlicense)))
+
+(define-public cl-class-options
+ (sbcl-package->cl-source-package sbcl-class-options))
+
+(define-public ecl-class-options
+ (sbcl-package->ecl-package sbcl-class-options))
+
(define-public sbcl-smug
(let ((commit "647a2428df297e1dd183ba7c19574bdb1320ae79")
(revision "0"))