summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-02-24 13:58:16 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2023-02-24 15:50:35 +0100
commitda16d56773ae6b69103fae71c03d87d4b05e4a5f (patch)
tree35c58dc9b8f6ea733893a1746112baeebf12fcc5 /gnu/packages/lisp-xyz.scm
parent57a06374143de29311de2c7731fc79479386962b (diff)
gnu: cl-clx: Update to 0.7.5-1.3840045.
* gnu/packages/lisp-xyz.scm (sbcl-clx): Update to 0.7.5-1.3840045. [native-inputs]: Add xorg-server-for-tests. [arguments]: Add 'prepare-test-environment' phase.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm50
1 files changed, 29 insertions, 21 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 00fa78909c..7fa700bfbb 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -1905,30 +1905,38 @@ files.")
(sbcl-package->cl-source-package sbcl-cl-pdf))
(define-public sbcl-clx
- (package
- (name "sbcl-clx")
- (version "0.7.5")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/sharplispers/clx")
- (commit version)))
- (sha256
- (base32
- "1vi67z9hpj5rr4xcmfbfwzmlcc0ah7hzhrmfid6lqdkva238v2wf"))
- (file-name (string-append "clx-" version))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- (list sbcl-fiasco))
- (home-page "https://www.cliki.net/portable-clx")
- (synopsis "X11 client library for Common Lisp")
- (description "CLX is an X11 client library for Common Lisp. The code was
+ (let ((commit "38400456d66823e417d1d27d339b09885e25eb59")
+ (revision "1"))
+ (package
+ (name "sbcl-clx")
+ (version (git-version "0.7.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/sharplispers/clx")
+ (commit commit)))
+ (sha256
+ (base32 "1c05gjqh5lil2sgma0yap4mxd9y1cjkp933hyx1iaj14950nhfnl"))
+ (file-name (git-file-name "cl-clx" version))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-fiasco xorg-server-for-tests))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'prepare-test-environment
+ (lambda _
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1"))))))
+ (home-page "https://www.cliki.net/portable-clx")
+ (synopsis "X11 client library for Common Lisp")
+ (description "CLX is an X11 client library for Common Lisp. The code was
originally taken from a CMUCL distribution, was modified somewhat in order to
make it compile and run under SBCL, then a selection of patches were added
from other CLXes around the net.")
- (license license:x11)))
+ (license license:x11))))
(define-public cl-clx
(sbcl-package->cl-source-package sbcl-clx))