summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-19 21:08:30 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 21:57:32 +0000
commit56fd98238b1eb415e6055f70d0c83fc0f0eb026c (patch)
tree5461ff24b4c6608f94f501cab2b2bfdc2109ba3b /gnu/packages/lisp-xyz.scm
parent78b4f2bc44ea8a2e3a545346d98e4d946685b48a (diff)
gnu: Add cl-st-json.
* gnu/packages/lisp-xyz.scm (cl-st-json, ecl-st-json, sbcl-st-json): New variables. Change-Id: Ib349cfb6fb7da17741f331215e9a4d46bc4866c0
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 35b667ada5..9bea6d8d78 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -251,6 +251,39 @@ accessors, hash-tables, sets, uiop:run-program, arrays and a few others.")
;; TODO: Tests fail on call to coreutils echo for ecl.
`(#:tests? #f))))
+(define-public sbcl-st-json
+ (let ((commit "4a0025bcc5b6921454822f1b9f38f697b4eeaf43")
+ (revision "0"))
+ (package
+ (name "sbcl-st-json")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marijnh/ST-JSON")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06qrhr5iw73k96lai2x9w52l6gnmlxy7fsr0r35gz6nz1f71x7gx"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://marijnhaverbeke.nl/st-json/")
+ (synopsis "JSON for Common Lisp")
+ (description
+ "ST-JSON (@code{ST} because it originated at Streamtech) is a Common Lisp
+ library for encoding and decoding JSON values (as specified on json.org).
+
+This library does mostly the same thing as CL-JSON, but is simpler and more
+precise about types (distinguishing boolean false, the empty array, and the
+empty object).")
+ (license license:zlib))))
+
+(define-public cl-st-json
+ (sbcl-package->cl-source-package sbcl-st-json))
+
+(define-public ecl-st-json
+ (sbcl-package->ecl-package sbcl-st-json))
+
(define-public sbcl-stdutils
(let ((commit "4a4e5a4036b815318282da5dee2a22825369137b")
(revision "0"))