summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-19 21:13:50 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 21:57:33 +0000
commit869954270fed3ee583091991661be7842d90fa8c (patch)
treedba4b81da41e0804f935993a284bb15dececb3da /gnu/packages/lisp-xyz.scm
parent3cd6076ebfa5c9a5837e43a8727f61bad03ebf39 (diff)
gnu: Add cl-easy-routes.
* gnu/packages/lisp-xyz.scm (cl-easy-routes, ecl-easy-routes, sbcl-easy-routes): New variables. Change-Id: Ic8d7413faf4b7e23775cc9c10b1b3da6494433d0
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1a2d9aba6d..1b17dd1d28 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2991,6 +2991,57 @@ management.")
(define-public ecl-eager-future2
(sbcl-package->ecl-package sbcl-eager-future2))
+(define-public sbcl-easy-routes
+ (let ((commit "7832f8bf3d07825b5eb967a2ef04da7c40c18248")
+ (revision "0"))
+ (package
+ (name "sbcl-easy-routes")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mmontone/easy-routes")
+ (commit commit)))
+ (file-name (git-file-name "cl-easy-routes" version))
+ (sha256
+ (base32 "1banw54kz2llzb9h5sm47ckfc9l348m7qncm0npsy0w837rxkyzx"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:asd-systems '("easy-routes"
+ "easy-routes+djula"
+ "easy-routes+errors")))
+ (native-inputs
+ (list sbcl-stefil))
+ (inputs
+ (list sbcl-djula
+ sbcl-hunchentoot
+ sbcl-hunchentoot-errors
+ sbcl-routes))
+ (home-page "https://github.com/mmontone/easy-routes/")
+ (synopsis "Routes handling utility on top of Hunchentoot")
+ (description
+ "EASY-ROUTES is yet another routes handling system on top of
+Hunchentoot. It's just glue code for Restas routing subsystem (CL-ROUTES).
+
+It supports:
+@itemize
+@item dispatch based on HTTP method
+@item arguments extraction from the url path
+@item decorators
+@item URL generation from route names
+@end itemize
+
+This package provides EASY-ROUTES, EASY-ROUTES+DJULA and EASY-ROUTES+ERRORS
+systems.")
+ (license license:expat))))
+
+(define-public cl-easy-routes
+ (sbcl-package->cl-source-package sbcl-easy-routes))
+
+(define-public ecl-easy-routes
+ (sbcl-package->ecl-package sbcl-easy-routes))
+
(define-public sbcl-jpl-util
(let ((commit "0311ed374e19a49d43318064d729fe3abd9a3b62"))
(package