summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-24 23:15:03 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2023-04-26 15:08:15 +0200
commit870f2d40e055d57659dff0dc20b903522f055bb0 (patch)
treec0a893fd81a26110c38cfe30f49a49a8098b1e29 /gnu/packages/lisp-xyz.scm
parente129321f137ad954570a2e239bf662ea87687ac8 (diff)
gnu: Add cl-chlorophyll.
* gnu/packages/lisp-xyz.scm (cl-chlorophyll, ecl-chlorophyll, sbcl-chlorophyll): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 196cf21e20..ec5918294c 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -23762,6 +23762,37 @@ This package provides the text-based interface for Chemboy.")
(define-public ecl-chemboy
(sbcl-package->ecl-package sbcl-chemboy))
+(define-public sbcl-chlorophyll
+ (let ((commit "f2a50ad36d2fb11823c0e5a8da08a0de89c5c35f")
+ (revision "1"))
+ (package
+ (name "sbcl-chlorophyll")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorozhin/chlorophyll")
+ (commit commit)))
+ (file-name (git-file-name "cl-chlorophyll" version))
+ (sha256
+ (base32 "1hgl8sjsmyqx4gs77q4p94b63zgpxk1wi9w9niki8j0213dr1s3y"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs (list sbcl-fiveam))
+ (inputs (list sbcl-alexandria))
+ (home-page "https://github.com/gorozhin/chlorophyll")
+ (synopsis "ANSI escape code library for Common Lisp")
+ (description
+ "This package provides a Common Lisp system CHLOROPHYLL which
+implements an ANSI escape code functionality.")
+ (license license:expat))))
+
+(define-public cl-chlorophyll
+ (sbcl-package->cl-source-package sbcl-chlorophyll))
+
+(define-public ecl-chlorophyll
+ (sbcl-package->ecl-package sbcl-chlorophyll))
+
(define-public sbcl-cl-pass
(let ((commit "e58e97c0c0588dc742c061208afb9bc31e4dbd34")
(revision "1"))