summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-01-23 16:16:18 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2021-01-24 11:39:16 +0100
commitbc14c6a400ce83eb0319ca989f7387a596fa40bd (patch)
tree855fc007337859474ebadcfdebd3628ca8ceda08 /gnu/packages/lisp-xyz.scm
parent13e18b32699daa4079b9edf16fd63961330e275b (diff)
gnu: Add concrete-syntax-tree.
* gnu/packages/lisp-xyz.scm (cl-concrete-syntax-tree, ecl-concrete-syntax-tree, sbcl-concrete-syntax-tree): New variables.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index ab1f191221..3acc1acb7b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13354,3 +13354,44 @@ source files.")
(define-public cl-indentify
(sbcl-package->cl-source-package sbcl-cl-indentify))
+
+(define-public sbcl-concrete-syntax-tree
+ (let ((commit "abd242a59dadc5452aa9dbc1d313c83ec2c11f46"))
+ (package
+ (name "sbcl-concrete-syntax-tree")
+ (version (git-version "0.0.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/s-expressionists/Concrete-Syntax-Tree")
+ (commit commit)))
+ (file-name (git-file-name name commit))
+ (sha256
+ (base32 "1lyrglc3h1if44gxd9cwv90wa90nrdjvb7fry39b1xn8ywdfa7di"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("acclimation" ,sbcl-acclimation)))
+ (home-page "https://github.com/s-expressionists/Concrete-Syntax-Tree")
+ (synopsis "Parse Common Lisp code into a concrete syntax tree")
+ (description
+ "This library is intended to solve the problem of source tracking for
+Common Lisp code.
+
+By \"source tracking\", it is meant that code elements that have a known
+origin in the form of a position in a file or in an editor buffer are
+associated with some kind of information about this origin.
+
+Since the exact nature of such origin information depends on the Common Lisp
+implementation and the purpose of wanting to track that origin, the library
+does not impose a particular structure of this information. Instead, it
+provides utilities for manipulating source code in the form of what is called
+concrete syntax trees (CSTs for short) that preserve this information about
+the origin.")
+ (license license:bsd-2))))
+
+(define-public ecl-concrete-syntax-tree
+ (sbcl-package->ecl-package sbcl-concrete-syntax-tree))
+
+(define-public cl-concrete-syntax-tree
+ (sbcl-package->cl-source-package sbcl-concrete-syntax-tree))