summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-11-16 08:06:14 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-11-16 10:34:42 +0100
commit56f73178e4a2e50f1bc9c5553117000f1781fad9 (patch)
treee9f6ee708993b0e6825c625b49fef81239e2572d /gnu/packages/lisp-xyz.scm
parentfd34760e2837ed6d81bd6602b584f83eaaf2f824 (diff)
gnu: Add cl-wu-decimal.
* gnu/packages/lisp-xyz.scm (sbcl-wu-decimal, cl-wu-decimal, ecl-wu-decimal): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 7af6f6ad34..ac3144c94e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20549,6 +20549,38 @@ command in Common Lisp.")
(define-public ecl-which
(sbcl-package->ecl-package sbcl-which))
+(define-public sbcl-wu-decimal
+ (let ((commit "5b348bdb32a0f83e80e17aa68cd51787ae8c8a45")
+ (revision "0"))
+ (package
+ (name "sbcl-wu-decimal")
+ (version (git-version "2.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Wukix/wu-decimal")
+ (commit commit)))
+ (file-name (git-file-name "cl-wu-decimal" version))
+ (sha256
+ (base32 "1p7na4hic7297amwm4idfwkyx664ny8cdssncyra37pmv4wzp8dm"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/Wukix/wu-decimal")
+ (synopsis "Arbitrary-precision decimal arithmetic")
+ (description
+ "Wu-Decimal enables convenient, arbitrary-precision decimal arithmetic
+through a reader macro, @code{#$}, and an update to the @code{pprint} dispatch
+table. Wu-Decimal uses the CL rational type to store decimals, which enables
+numeric functions such as @code{+}, @code{-}, etc., to operate on decimal
+numbers in a natural way.")
+ (license license:bsd-2))))
+
+(define-public cl-wu-decimal
+ (sbcl-package->cl-source-package sbcl-wu-decimal))
+
+(define-public ecl-wu-decimal
+ (sbcl-package->ecl-package sbcl-wu-decimal))
+
(define-public sbcl-cl-num-utils
(let ((commit "97a88cd34540acf52e872a82ebfef3da0a34fa12")
(revision "1"))