summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-11-19 22:43:41 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-11-20 14:45:00 +0100
commit9c2d6ddfbed949d55230cb785d0245f5ef21daa6 (patch)
treec710fb31ffe7a59c9490ae85a0b55bd1b5bfde30 /gnu/packages/lisp-xyz.scm
parentae90aaa60cbfd9a05b0d9f9c4d6963187e0fa6e1 (diff)
gnu: Add cl-virality.
* gnu/packages/lisp-xyz.scm (cl-virality, sbcl-virality): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index cde879f210..d3f2db9fff 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -19164,6 +19164,72 @@ fit together as required by any particular game.")
(define-public cl-trial
(sbcl-package->cl-source-package sbcl-trial))
+(define-public sbcl-virality
+ (package
+ (name "sbcl-virality")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bufferswap/ViralityEngine")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "cl-virality" version))
+ (sha256
+ (base32 "0hvjcvyd628jh4if6swk1wrfb9qdlnpk9ax1y3jarr8ms7ghfcdb"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-systems '("virality"
+ "vorigin"
+ "vorigin.test"
+ "vshadow"
+ "vumbra"
+ "vutils")))
+ (inputs
+ (list sbcl-3b-bmfont
+ sbcl-babel
+ sbcl-cl-cpus
+ sbcl-cl-graph
+ sbcl-cl-opengl
+ sbcl-cl-ppcre
+ sbcl-cl-slug
+ sbcl-closer-mop
+ sbcl-fast-io
+ sbcl-global-vars
+ sbcl-glsl-packing
+ sbcl-jsown
+ sbcl-lparallel
+ sbcl-pngload
+ sbcl-printv
+ sbcl-queues
+ sbcl-sdl2
+ sbcl-serapeum
+ sbcl-split-sequence
+ sbcl-static-vectors
+ sbcl-trivial-features
+ sbcl-varjo))
+ (home-page "https://github.com/bufferswap/ViralityEngine")
+ (synopsis "Component-based game engine written in Common Lisp")
+ (description
+ "Virality Engine provides a system and workflow that helps describe the
+elements needed to write 2D or 3D games. It was designed with several domain
+specific languages that make it easier to describe, manipulate, and use assets
+commonly found in game making. Such assets include (but are not limited to)
+textures, materials, shader programs, and scene trees of actors that are
+available for instantiation. Virality Engine also knows how to accept input
+from keyboards and most joysticks and gamepads.
+
+The component system is a hybrid model between an ECS and an object model. The
+components are defined similar to CLOS defclass, and regular generic methods
+can be used with them. Components are added to Actors which represent game
+concepts like players, scenery, effects, etc. We define a component protocol
+invoked by Virality Engine to move your components to the next state and
+render them each frame.")
+ (license license:expat)))
+
+(define-public cl-virality
+ (sbcl-package->cl-source-package sbcl-virality))
+
(define-public sbcl-cl-liballegro
(let ((commit "49f632ce97fc4f835bf5d450588793234b980a64")
(revision "1"))