summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-12-11 18:08:00 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-12-11 19:17:00 +0100
commit6e301c3a53270301bf2685f59b470a88b521105f (patch)
treee5428e3d0a7d993f516e0446de27d61d3aa8a5e6 /gnu/packages/lisp-xyz.scm
parent4a084c7a7b8e64e4598fd7149b77c8b79d5b5c56 (diff)
gnu: sbcl-geco: Update to 2.1.1.
* gnu/packages/lisp-xyz.scm (sbcl-geco): Update to 2.1.1. [source]: Fetch from Github. [home-page]: Update to author's page. * gnu/packages/patches/sbcl-geco-fix-organism-class.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 68adff3169..747617fdda 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11234,17 +11234,18 @@ XML to Lisp structures or s-expressions and back.")
(define-public sbcl-geco
(package
(name "sbcl-geco")
- (version "2.01a")
+ (version "2.1.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://common-lisp.net/project/geco/download/"
- "geco-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gpwwjr/GECO")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "geco" version))
(sha256
- (base32 "0kk0bzr1019cfmf2b1jl1rk9shv3gx5z1znifxllg9mb98yqsgw0"))
- (patches (search-patches "sbcl-geco-fix-organism-class.patch"))))
+ (base32 "1rc8a4mk40hjx5qy980hjylv6xxqdbq38hg8c4w30y93abfd519s"))))
(build-system asdf-build-system/sbcl)
- (home-page "https://common-lisp.net/project/geco/")
+ (home-page "http://hiwaay.net/~gpw/geco/geco.html")
(synopsis "Genetic algorithm toolkit for Common Lisp")
(description
"GECO (Genetic Evolution through Combination of Objects) is an extensible,