summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorAdam Kandur <rndd@tuta.io>2020-08-12 09:52:05 +0300
committerLeo Famulari <leo@famulari.name>2020-08-22 14:21:58 -0400
commitca7eada91819c7cd5a78e144d285cd972a478a0c (patch)
treed0343be8d1b47d247be9c8d74e273c40840d664e /gnu/packages/lisp-xyz.scm
parente5391dcc6b4267b81c98b5c019317d68f5e9f47e (diff)
gnu: Add sbcl-livesupport.
* gnu/packages/lisp-xyz.scm (sbcl-livesupport, cl-livesupport, ecl-livesupport): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b8216b04e1..904d202a55 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13509,3 +13509,33 @@ for an example.")
(define-public ecl-hu.dwim.defclass-star
(sbcl-package->ecl-package sbcl-hu.dwim.defclass-star))
+
+(define-public sbcl-livesupport
+ (let ((commit "71e6e412df9f3759ad8378fabb203913d82e228a")
+ (revision "1"))
+ (package
+ (name "sbcl-livesupport")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cbaggers/livesupport")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rvnl0mncylbx63608pz5llss7y92j7z3ydambk9mcnjg2mjaapg"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/cbaggers/livesupport")
+ (synopsis "Some helpers that make livecoding a little easier")
+ (description "This package provides a macro commonly used in livecoding to
+enable continuing when errors are raised. Simply wrap around a chunk of code
+and it provides a restart called @code{continue} which ignores the error and
+carrys on from the end of the body.")
+ (license license:bsd-2))))
+
+(define-public cl-livesupport
+ (sbcl-package->cl-source-package sbcl-livesupport))
+
+(define-public ecl-livesupport
+ (sbcl-package->ecl-package sbcl-livesupport))