summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-11-09 19:07:10 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-11-09 19:07:10 +0100
commit6b8868910cd2647c30a9debd5962cf2ca8d45e1b (patch)
tree46d8972a51b75e3daadf2f96bf9eadefc086ea4e /gnu/packages/lisp-xyz.scm
parente744328acb14e8cd21ae5e990ca7551e045ddcdb (diff)
gnu: Add cl-environments.
* gnu/packages/lisp-xyz.scm (cl-environments): New variable.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index bc92ce64da..dfc16102de 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -14372,3 +14372,37 @@ collecting values easier.")
(define-public ecl-collectors
(sbcl-package->ecl-package sbcl-collectors))
+
+(define-public cl-environments
+ ;; TODO: asdf-build-system/sbcl fails here, why? See if it works with the
+ ;; build system revamp once staging is merged after 2020-11-09.
+ (package
+ (name "cl-environments")
+ (version "0.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alex-gutev/cl-environments")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08w364if2ivxwdarz44vwk0s61zk8l8pnrwskaghbrjg3his1nmd"))))
+ (build-system asdf-build-system/source)
+ (propagated-inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("anaphora" ,sbcl-anaphora)
+ ("collectors" ,sbcl-collectors)
+ ("optima" ,sbcl-optima)))
+ (native-inputs
+ `(("prove" ,sbcl-prove)
+ ("prove-asdf" ,sbcl-prove-asdf)))
+ (home-page "https://github.com/alex-gutev/cl-environments")
+ (synopsis "Implements the Common Lisp standard environment access API")
+ (description "This library provides a uniform API, as specified in Common
+Lisp the Language 2, for accessing information about variable and function
+bindings from implementation-defined lexical environment objects. All major
+Common Lisp implementations are supported, even those which don't support the
+CLTL2 environment access API.")
+ (license license:expat)))