summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-11-09 19:38:22 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-11-10 09:59:49 +0100
commit9f78a37f52a12474d1eb61f789b159c4ea3134b7 (patch)
treea698ca87892183b5a69ffc0aaccff9a699c9e18d /gnu/packages/lisp-xyz.scm
parentacb9f7849f7f9c2fb22585f45efaaa8ea397dd70 (diff)
gnu: cl-environments: Update to 20200401.
* gnu/packages/lisp-xyz.scm (cl-environments): Update to 20200401. This includes the :tools package not present in 0.2.3.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm53
1 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index bdfb152538..ab70724425 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -14376,36 +14376,37 @@ collecting values easier.")
(define-public cl-environments
;; TODO: asdf-build-system/sbcl fails here, why? See if it works with the
;; build system revamp once staging is merged after 2020-11-09.
- (package
- (name "cl-environments")
- (version "0.2.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alex-gutev/cl-environments")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "08w364if2ivxwdarz44vwk0s61zk8l8pnrwskaghbrjg3his1nmd"))))
- (build-system asdf-build-system/source)
- (propagated-inputs
- `(("alexandria" ,sbcl-alexandria)
- ("anaphora" ,sbcl-anaphora)
- ("collectors" ,sbcl-collectors)
- ("optima" ,sbcl-optima)))
- (native-inputs
- `(("prove" ,sbcl-prove)
- ("prove-asdf" ,sbcl-prove-asdf)))
- (home-page "https://github.com/alex-gutev/cl-environments")
- (synopsis "Implements the Common Lisp standard environment access API")
- (description "This library provides a uniform API, as specified in Common
+ (let ((commit "bbcd958a9ff23ce3e6ea5f8ee2edad9634819a3a")) ; No version in 2 years.
+ (package
+ (name "cl-environments")
+ (version (git-version "0.2.3" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alex-gutev/cl-environments")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pfxl3vcdrb4mjy4q4c3c7q95kzv6rfjif3hzd5q91i9z621d64r"))))
+ (build-system asdf-build-system/source)
+ (propagated-inputs
+ `(("alexandria" ,cl-alexandria)
+ ("anaphora" ,cl-anaphora)
+ ("collectors" ,cl-collectors)
+ ("optima" ,cl-optima)))
+ (native-inputs
+ `(("prove" ,sbcl-prove)
+ ("prove-asdf" ,sbcl-prove-asdf)))
+ (home-page "https://github.com/alex-gutev/cl-environments")
+ (synopsis "Implements the Common Lisp standard environment access API")
+ (description "This library provides a uniform API, as specified in Common
Lisp the Language 2, for accessing information about variable and function
bindings from implementation-defined lexical environment objects. All major
Common Lisp implementations are supported, even those which don't support the
CLTL2 environment access API.")
- (license license:expat)))
+ (license license:expat))))
(define-public sbcl-static-dispatch
(package