summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorAndre A. Gomes <andremegafone@gmail.com>2023-07-18 12:32:31 +0300
committerGuillaume Le Vaillant <glv@posteo.net>2023-07-19 09:12:01 +0200
commit324f56927b5856d9b7629c594e7d2893916e8c16 (patch)
tree8e47c077c4e912121b24cf53580152e2874ab33e /gnu/packages/lisp-xyz.scm
parent54a49cf1ccc9d2cf44e5de5bdd0ce5fc7c810fb0 (diff)
gnu: cl-ndebug: Update to 0.2.0.
* gnu/packages/lisp-xyz.scm (sbcl-ndebug): Update to 0.2.0. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 7c869f3a0e..eeda615c95 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -27956,23 +27956,22 @@ manipulations as the composition of more primitive operations.")
(define-public sbcl-ndebug
(package
(name "sbcl-ndebug")
- (version "0.1.0")
+ (version "0.2.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/atlas-engineer/ndebug")
(commit version)))
- (file-name (git-file-name "ndebug" version))
+ (file-name (git-file-name "cl-ndebug" version))
(sha256
- (base32 "0wdp0wqk6clq3hh9yqmgdm55x50b5m7ly9004j2c8k5zz1rgi4rr"))))
+ (base32 "1sndg4qclkdr53xkxrfjskx8gcqx0bn4r0vslzfx1kgznl4hbf1d"))))
(build-system asdf-build-system/sbcl)
(inputs
- (list
- sbcl-dissect
- sbcl-lparallel
- sbcl-slime-swank
- sbcl-trivial-custom-debugger))
+ (list sbcl-dissect
+ sbcl-trivial-custom-debugger
+ sbcl-bordeaux-threads
+ sbcl-trivial-gray-streams))
(native-inputs
(list sbcl-lisp-unit2))
(home-page "https://github.com/atlas-engineer/ndebug/")