summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2023-12-29 12:28:52 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2024-01-04 16:38:19 +0100
commit466975efea86727465f75a4e2c54e9eeb212f4a6 (patch)
tree1b392ebe46550cb49f6c8f1a74426ed5972503ea /gnu/packages/lisp-xyz.scm
parent4440ba3f6ee1f6936755b2eb1e9d60108d2f9c72 (diff)
gnu: cl-alexandria: Update to 1.4-0.009b7e5.
* gnu/packages/lisp-xyz.scm (sbcl-alexandria): Update to 1.4-0.009b7e5. [file-name]: Rename to cl-alexandria. Move above sha256. Change-Id: I7122aff13715d24e99a58fa4b55b0ef012ae8c40 Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index aa3ea7c9ce..3023bf07db 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -168,29 +168,30 @@
(sbcl-package->ecl-package sbcl-alexandria-plus))
(define-public sbcl-alexandria
- (package
- (name "sbcl-alexandria")
- (version "1.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.common-lisp.net/alexandria/alexandria.git")
- (commit (string-append "v" version))))
- (sha256
- (base32
- "0r1adhvf98h0104vq14q7y99h0hsa8wqwqw92h7ghrjxmsvz2z6l"))
- (file-name (git-file-name name version))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- (list sbcl-rt))
- (synopsis "Collection of portable utilities for Common Lisp")
- (description
- "Alexandria is a collection of portable utilities. It does not contain
+ (let ((commit "009b7e532071d9777bdbd63b82d776555da95916")
+ (revision "0"))
+ (package
+ (name "sbcl-alexandria")
+ (version (git-version "1.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.common-lisp.net/alexandria/alexandria.git")
+ (commit commit)))
+ (file-name (git-file-name "cl-alexandria" version))
+ (sha256
+ (base32 "0pdj779j3nwzn8f1661vf00rrjrbks1xgiq0rvwjw6qyxsfqfnl9"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-rt))
+ (synopsis "Collection of portable utilities for Common Lisp")
+ (description
+ "Alexandria is a collection of portable utilities. It does not contain
conceptual extensions to Common Lisp. It is conservative in scope, and
portable between implementations.")
- (home-page "https://common-lisp.net/project/alexandria/")
- (license license:public-domain)))
+ (home-page "https://common-lisp.net/project/alexandria/")
+ (license license:public-domain))))
(define-public cl-alexandria
(sbcl-package->cl-source-package sbcl-alexandria))