summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-06-05 14:03:23 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-06-06 10:46:45 +0200
commit9ad8b0c2ef10d8de01bad25f54337c5df35aa842 (patch)
treebd1e2f33c447069df0cd8b5ea11663fc2f27a112 /gnu/packages/lisp-xyz.scm
parentb30c60316c9c82f97bd38985980613f2a755d870 (diff)
gnu: sbcl-stmx: Update to 2.0.5-2.f71e742.
* gnu/packages/lisp-xyz.scm (sbcl-stmx): Update to 2.0.5-2.f71e742. [arguments]: Add 'fix-build' phase.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fd09b4f52c..8031ef5365 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -21176,9 +21176,10 @@ window it creates as just another output for your graphics, analogous to how
(sbcl-package->cl-source-package sbcl-cepl))
(define-public sbcl-stmx
- ;; No release for years and recent commits contain fixes for revent SBCL versions.
- (let ((commit "a7bb44082cd53ee968965adff03d4351750711a1")
- (revision "1"))
+ ;; No release for years and recent commits contain fixes for recent SBCL
+ ;; versions.
+ (let ((commit "f71e742a50b85e3abc0af9bb5f02802f218a1705")
+ (revision "2"))
(package
(name "sbcl-stmx")
(version (git-version "2.0.5" revision commit))
@@ -21190,11 +21191,22 @@ window it creates as just another output for your graphics, analogous to how
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "1hfmh4vj271jdilir97qs6nqbi5nmn5alyls0w3d3xxqwi6ffqjs"))))
+ (base32 "0q739mlw3s3z5kclzccz4r64ag38ks11fmd38109qwjv5knn69jv"))))
(build-system asdf-build-system/sbcl)
(inputs
(list sbcl-alexandria sbcl-bordeaux-threads sbcl-log4cl
sbcl-closer-mop sbcl-trivial-garbage))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ (lambda _
+ (substitute* "asm/transaction.lisp"
+ (("\\(ftype \\(function \\(\\) fixnum\\) transaction-begin\\)")
+ "(ftype (function () (unsigned-byte 32)) transaction-begin)")
+ (("\\(values fixnum &optional\\)")
+ "(unsigned-byte 32)")))))))
(home-page "https://stmx.org/")
(synopsis "High performance Transactional Memory for Common Lisp")
(description