summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-03-22 16:57:36 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-27 10:49:05 +0200
commitacbdaec070f39b723a1b964ffa7fbd4b640bbd8e (patch)
tree95db11662826ae00b01dd4e1d1279eda7a5fb0e1 /gnu/packages/lisp-xyz.scm
parent288bc147336e1b4080d66fa86d4ab3323f845cb5 (diff)
gnu: Add cl-osc.
* gnu/packages/lisp-xyz.scm (cl-osc, ecl-osc, sbcl-osc): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index a2f56e06e9..e0025b784c 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -23959,6 +23959,37 @@ Vernacular builds on Overlord and is inspired by Racket.")
(define-public cl-vernacular
(sbcl-package->cl-source-package sbcl-vernacular))
+(define-public sbcl-osc
+ (let ((commit "9f0a9d3da310a3a0f654f48af0203816f3f371ad")
+ (revision "0"))
+ (package
+ (name "sbcl-osc")
+ (version (git-version "0.7" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zzkt/osc")
+ (commit commit)))
+ (file-name (git-file-name "cl-osc" version))
+ (sha256
+ (base32 "0gh29zcl9pmy3xlmwzpf9www2z06ah6b4jk06sj2cvxbc15nblqa"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs (list sbcl-usocket))
+ (synopsis "Implementation of the Open Sound Control protocol")
+ (description "This package provides a common lisp implementation
+of the Open Sound Control Protocol aka OSC. The code should be close
+to the ansi standard, and does not rely on any external code/ffi/etc+
+to do the basic encoding and decoding of packets.")
+ (home-page "https://github.com/zzkt/osc/")
+ (license (list license:gpl3 license:llgpl)))))
+
+(define-public cl-osc
+ (sbcl-package->cl-source-package sbcl-osc))
+
+(define-public ecl-osc
+ (sbcl-package->ecl-package sbcl-osc))
+
(define-public sbcl-cmn
(package
(name "sbcl-cmn")