summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-05 17:09:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-05 17:09:53 -0400
commitd3a0869e9b667d563e7e877c93f30a70896c5831 (patch)
tree15460b434f44cf76916947ed2afbe848c43311d2 /gnu/packages/lisp.scm
parent70b0f2b9134b2db286f707835394798de039c277 (diff)
parent5694352c05ed4fdb57a9843d8f023ca3d85992c3 (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 6f425a6e4a..c54a9b4b3a 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2019-2023 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
-;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
@@ -25,6 +25,7 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2023 Andrew Kravchuk <awkravchuk@gmail.com.
;;;
;;; This file is part of GNU Guix.
;;;
@@ -266,7 +267,7 @@ interface to the Tk widget system.")
(define-public ecl
(package
(name "ecl")
- (version "21.2.1")
+ (version "23.9.9")
(source
(origin
(method url-fetch)
@@ -274,7 +275,7 @@ interface to the Tk widget system.")
"https://ecl.common-lisp.dev/static/files/release/"
name "-" version ".tgz"))
(sha256
- (base32 "000906nnq25177bgsfndiw3iqqgrjc9spk10hzk653sbz3f7anmi"))))
+ (base32 "107q6gmxlsya4yv38r1x1axrgyyfgdrfkkz97zfp64bcrasdl6y5"))))
(build-system gnu-build-system)
;; src/configure uses 'which' to confirm the existence of 'gzip'.
(native-inputs
@@ -346,6 +347,7 @@ interface to the Tk widget system.")
(files '("etc")))))
(home-page "https://ecl.common-lisp.dev/")
(synopsis "Embeddable Common Lisp")
+ (supported-systems (delete "i586-gnu" %supported-systems))
(description "ECL is an implementation of the Common Lisp language as
defined by the ANSI X3J13 specification. Its most relevant features are: a
bytecode compiler and interpreter, being able to compile Common Lisp with any
@@ -380,6 +382,10 @@ supporting ASDF, Sockets, Gray streams, MOP, and other useful components.")
(%current-target-system)))
'("CFLAGS=-falign-functions=4")
'())
+ ,@(if (target-x86-64?)
+ '("--enable-portability"
+ "--with-threads=POSIX_THREADS")
+ '())
"--with-dynamic-ffi"
"--with-dynamic-modules"
"--with-ffcall"
@@ -433,17 +439,15 @@ an interpreter, a compiler, a debugger, and much more.")
(define-public sbcl
(package
(name "sbcl")
- (version "2.3.5")
+ (version "2.3.7")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/sbcl/sbcl/" version "/sbcl-"
version "-source.tar.bz2"))
(sha256
- (base32 "11ji5n65l31249r0v7hm0wc0yk2ila0y746nj36xn1cxrwh0gjc9"))
+ (base32 "1xwr1pnwd3xj375ainlad7mm479rk2mrks8dc6d92cash3xl90b9"))
(modules '((guix build utils)))
- ;; backport from upstream.
- (patches (search-patches "sbcl-riscv-Make-contribs-build-again.patch"))
(snippet
'(begin
;; Don't force ARMv5.
@@ -668,6 +672,7 @@ an interpreter, a compiler, a debugger, and much more.")
(variable "XDG_CONFIG_DIRS")
(files '("etc")))))
(home-page "https://www.sbcl.org/")
+ (supported-systems (delete "i586-gnu" %supported-systems))
(synopsis "Common Lisp implementation")
(description "Steel Bank Common Lisp (SBCL) is a high performance Common
Lisp compiler. In addition to the compiler and runtime system for ANSI Common