summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2024-01-25 12:29:30 +0100
committerAndreas Enge <andreas@enge.fr>2024-01-26 10:09:35 +0100
commitf027a6c22c6cefe10cdd46821168bc9261111d5b (patch)
tree1492219aa59fa296ee36d89f330a2603f36d906c /gnu/packages/lisp.scm
parent619417ab232094ae4fd5396139289983b7a0d22f (diff)
gnu: s7: Compile with flint@3.
* gnu/packages/patches/s7-flint-3.patch: New file. * gnu/local.mk (dist_patch_DATA): Register file. * gnu/packages/lisp.scm (s7-bootstrap)[source]: Add patch. [inputs]: Remove arb. Change-Id: I06bac9d850977b8ee769e629f1b64411a8dc3247
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 8e614b7d90..29d5ddebdc 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -25,7 +25,8 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
-;;; Copyright © 2023 Andrew Kravchuk <awkravchuk@gmail.com.
+;;; Copyright © 2023 Andrew Kravchuk <awkravchuk@gmail.com>
+;;; Copyright © 2024 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1502,7 +1503,8 @@ includes a compiler as well as an interpreter.")
(file-name (git-file-name name version))
(sha256
(base32
- "0fiw8lb7rswglixvn271la2q2hgwszrf2ckykhr6jjxdvmb9a7d0"))))
+ "0fiw8lb7rswglixvn271la2q2hgwszrf2ckykhr6jjxdvmb9a7d0"))
+ (patches (search-patches "s7-flint-3.patch"))))
(build-system gnu-build-system)
(arguments
(list #:tests? #f ;no tests in bootstrap
@@ -1533,7 +1535,7 @@ includes a compiler as well as an interpreter.")
(invoke #$(cc-for-target) "libarb_s7.c"
"-I." "-O2" "-g"
"-shared" "-o" "libarb_s7.so"
- "-larb" "-lflint" "-lmpc" "-fPIC")
+ "-lflint" "-lmpc" "-fPIC")
(display "[BUILD] libnotcurses_s7.so\n")
(invoke #$(cc-for-target) "notcurses_s7.c"
"-I." "-O2" "-g"
@@ -1572,7 +1574,7 @@ includes a compiler as well as an interpreter.")
(install-file "s7.c" share)
(install-file "s7.h" inc)
(install-file "s7.html" doc)))))))
- (inputs (list arb flint mpc notcurses))
+ (inputs (list flint mpc notcurses))
(home-page "https://ccrma.stanford.edu/software/snd/snd/s7.html")
(synopsis "Scheme interpreter intended as an extension language")
(description