summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-03-01 19:05:29 -0500
committerMark H Weaver <mhw@netris.org>2015-03-01 19:05:29 -0500
commit3820d3973982048e5b93ad08d619c893bc50de14 (patch)
tree159a3ea785647fb8bb5e4b754f5c0f98d86e29d5 /gnu/packages/lisp.scm
parent751be9a056114d353bac12510bea33e8d5577f49 (diff)
parentafff9058a0a9a3f3d633f563bb8a1a7d9e503165 (diff)
Merge branch 'master' into core-updates
Conflicts: gnu/packages/gnupg.scm
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm49
1 files changed, 28 insertions, 21 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 5db3fa98f9..c592fbd83f 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -97,7 +97,7 @@ interface to the Tk widget system.")
(define-public ecl
(package
(name "ecl")
- (version "13.5.1")
+ (version "15.2.21")
(source
(origin
(method url-fetch)
@@ -105,33 +105,40 @@ interface to the Tk widget system.")
(version-major+minor version)
"/ecl-" version ".tgz"))
(sha256
- (base32 "18ic8w9sdl0dh3kmyc9lsrafikrd9cg1jkhhr25p9saz0v75f77r"))))
+ (base32 "05di23v977byf67rq5bdshw8lqbby1ycbscdcl1vca0z6r1s204j"))))
(build-system gnu-build-system)
+ ;; src/configure uses 'which' to confirm the existence of 'gzip'.
(native-inputs `(("which" ,which)))
(inputs `(("gmp" ,gmp)
("libatomic-ops" ,libatomic-ops)
("libgc" ,libgc)
("libffi" ,libffi)))
(arguments
- '(#:phases
- ;; The test-suite seems to assume that ECL is installed. So re-order
- ;; the phases, then reference the installed executable.
- (let* ((check-phase (assq-ref %standard-phases 'check))
- (rearranged-phases
- (alist-cons-after 'install 'check check-phase
- (alist-delete 'check %standard-phases))))
- (alist-cons-before
- 'check 'pre-check
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* '("build/tests/Makefile")
- (("ECL=ecl")
- (string-append
- "ECL=" (assoc-ref outputs "out") "/bin/ecl"))))
- rearranged-phases))
- ;; Parallel builds explicitly not supported:
- ;; http://sourceforge.net/p/ecls/bugs/98/
- #:parallel-build? #f
- #:parallel-tests? #f))
+ '(#:tests? #f
+ ;; During 'make check', ECL fails to initialize with "protocol not
+ ;; supported", presumably because /etc/protocols is missing in the
+ ;; build environment. See <http://sourceforge.net/p/ecls/bugs/300/>.
+ ;;
+ ;; Should the test suite be re-enabled, it might be necessary to add
+ ;; '#:parallel-tests #f'. See the same bug report as above.
+ ;;
+ ;; The following might also be necessary, due to 'make check' assuming
+ ;; ECL is installed. See <http://sourceforge.net/p/ecls/bugs/299/>.
+ ;;
+ ;; #:phases
+ ;; (let* ((check-phase (assq-ref %standard-phases 'check))
+ ;; (rearranged-phases
+ ;; (alist-cons-after 'install 'check check-phase
+ ;; (alist-delete 'check %standard-phases))))
+ ;; (alist-cons-before
+ ;; 'check 'pre-check
+ ;; (lambda* (#:key outputs #:allow-other-keys)
+ ;; (substitute* '("build/tests/Makefile")
+ ;; (("ECL=ecl")
+ ;; (string-append
+ ;; "ECL=" (assoc-ref outputs "out") "/bin/ecl"))))
+ ;; rearranged-phases))
+ ))
(home-page "http://ecls.sourceforge.net/")
(synopsis "Embeddable Common Lisp")
(description "ECL is an implementation of the Common Lisp language as