summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-29 18:47:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-01 23:30:28 +0200
commitb693aa6e63f7719aeb9b5f737eff966f9074a399 (patch)
treedb025dfca27b882e5e817415e41d7598253abecd /gnu/packages/lisp.scm
parentdec63df4ff09d8db2fbeb090e86af7c7a8a8fc22 (diff)
gnu: Add sbcl-cl-ppcre-unicode.
* gnu/packages/lisp.scm (sbcl-cl-ppcre-unicode): New variable.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 64acc75e59..6887b320f8 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -881,6 +881,16 @@ from other CLXes around the net.")
(define-public ecl-clx
(sbcl-package->ecl-package sbcl-clx))
+(define-public sbcl-cl-ppcre-unicode
+ (package (inherit sbcl-cl-ppcre)
+ (name "sbcl-cl-ppcre-unicode")
+ (arguments
+ `(#:tests? #f ; tests fail with "Component :CL-PPCRE-TEST not found"
+ #:asd-file "cl-ppcre-unicode.asd"))
+ (inputs
+ `(("sbcl-cl-ppcre" ,sbcl-cl-ppcre)
+ ("sbcl-cl-unicode" ,sbcl-cl-unicode)))))
+
(define-public sbcl-stumpwm
(package
(name "sbcl-stumpwm")