summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-06-05 14:08:20 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-06-05 14:08:20 +0200
commit3a7fcfb34ef8cefb64c93d48e2d665a08fe3b8a1 (patch)
tree9cd86c804e420ca67da30b9c6e5db102938a37b7 /gnu/packages/lisp.scm
parent66294d7cfee011b80f13dfc87a69710d3460db07 (diff)
gnu: txr: Update to 239.
* gnu/packages/lisp.scm (txr): Update to 239. [arguments]: Use cc-for-target.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 498eee9526..a2e0f0724d 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -800,7 +800,7 @@ enough to play the original mainframe Zork all the way through.")
(define-public txr
(package
(name "txr")
- (version "238")
+ (version "239")
(source
(origin
(method git-fetch)
@@ -809,15 +809,12 @@ enough to play the original mainframe Zork all the way through.")
(commit (string-append "txr-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0asdq4n828xb1m31s7f47mqcbjqkzxz11bwnw8v3f2249m93ync4"))))
+ (base32 "1jldpkd5f855m3z4zjpd1ha64f405pcdwwrnr8jnk66v22dsvdwx"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "cc=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "--prefix=" (assoc-ref %outputs "out"))))
+ (list ,(string-append "cc=" (cc-for-target))
+ (string-append "--prefix=" (assoc-ref %outputs "out")))
#:test-target "tests"
#:phases
(modify-phases %standard-phases