summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-21 22:28:45 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-01 21:29:33 +0100
commitcb03a9b6a2eb50935d591039fdda2d2365358f24 (patch)
tree679941c149f613cc3ed2217a43c18f26522c6f30 /gnu/packages/lisp.scm
parent76212b57f6a2eb042186c1264c8ac04e0bce85e1 (diff)
gnu: ecl: Update to version 15.2.21.
* gnu/packages/lisp.scm (ecl): Update to version 15.2.21, and disable the test suite because ECL now fails to initialize during 'make check'.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm49
1 files changed, 28 insertions, 21 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 5db3fa98f9..c592fbd83f 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -97,7 +97,7 @@ interface to the Tk widget system.")
(define-public ecl
(package
(name "ecl")
- (version "13.5.1")
+ (version "15.2.21")
(source
(origin
(method url-fetch)
@@ -105,33 +105,40 @@ interface to the Tk widget system.")
(version-major+minor version)
"/ecl-" version ".tgz"))
(sha256
- (base32 "18ic8w9sdl0dh3kmyc9lsrafikrd9cg1jkhhr25p9saz0v75f77r"))))
+ (base32 "05di23v977byf67rq5bdshw8lqbby1ycbscdcl1vca0z6r1s204j"))))
(build-system gnu-build-system)
+ ;; src/configure uses 'which' to confirm the existence of 'gzip'.
(native-inputs `(("which" ,which)))
(inputs `(("gmp" ,gmp)
("libatomic-ops" ,libatomic-ops)
("libgc" ,libgc)
("libffi" ,libffi)))
(arguments
- '(#:phases
- ;; The test-suite seems to assume that ECL is installed. So re-order
- ;; the phases, then reference the installed executable.
- (let* ((check-phase (assq-ref %standard-phases 'check))
- (rearranged-phases
- (alist-cons-after 'install 'check check-phase
- (alist-delete 'check %standard-phases))))
- (alist-cons-before
- 'check 'pre-check
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* '("build/tests/Makefile")
- (("ECL=ecl")
- (string-append
- "ECL=" (assoc-ref outputs "out") "/bin/ecl"))))
- rearranged-phases))
- ;; Parallel builds explicitly not supported:
- ;; http://sourceforge.net/p/ecls/bugs/98/
- #:parallel-build? #f
- #:parallel-tests? #f))
+ '(#:tests? #f
+ ;; During 'make check', ECL fails to initialize with "protocol not
+ ;; supported", presumably because /etc/protocols is missing in the
+ ;; build environment. See <http://sourceforge.net/p/ecls/bugs/300/>.
+ ;;
+ ;; Should the test suite be re-enabled, it might be necessary to add
+ ;; '#:parallel-tests #f'. See the same bug report as above.
+ ;;
+ ;; The following might also be necessary, due to 'make check' assuming
+ ;; ECL is installed. See <http://sourceforge.net/p/ecls/bugs/299/>.
+ ;;
+ ;; #:phases
+ ;; (let* ((check-phase (assq-ref %standard-phases 'check))
+ ;; (rearranged-phases
+ ;; (alist-cons-after 'install 'check check-phase
+ ;; (alist-delete 'check %standard-phases))))
+ ;; (alist-cons-before
+ ;; 'check 'pre-check
+ ;; (lambda* (#:key outputs #:allow-other-keys)
+ ;; (substitute* '("build/tests/Makefile")
+ ;; (("ECL=ecl")
+ ;; (string-append
+ ;; "ECL=" (assoc-ref outputs "out") "/bin/ecl"))))
+ ;; rearranged-phases))
+ ))
(home-page "http://ecls.sourceforge.net/")
(synopsis "Embeddable Common Lisp")
(description "ECL is an implementation of the Common Lisp language as