summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-21 23:25:12 -0400
committerMark H Weaver <mhw@netris.org>2015-04-22 15:08:45 -0400
commit76eb726617327fa42faf7d16a34d459a7a5d37de (patch)
tree6e2247c5a91d653224189dc555ababa0eb450303 /gnu/packages/lisp.scm
parent4788deea0b029dedc8657a5175e89bc8eab3f27b (diff)
gnu: ccl: Add default 'match' cases for unsupported platforms.
* gnu/packages/lisp.scm (ccl)[arguments]: Add default 'match' cases for unsupported platforms.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 8f12efb9eb..feaa08af38 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -343,9 +343,13 @@ statistical profiler, a code coverage tool, and many other extensions.")
(chdir (string-append
"lisp-kernel/"
,(match (or (%current-target-system) (%current-system))
- ("i686-linux" "linuxx8632")
+ ("i686-linux" "linuxx8632")
("x86_64-linux" "linuxx8664")
- ("armhf-linux" "linuxarm"))))
+ ("armhf-linux" "linuxarm")
+ ;; Prevent errors when querying this package
+ ;; on unsupported platforms, e.g. when running
+ ;; "guix package --search="
+ (_ "UNSUPPORTED"))))
(substitute* '("Makefile")
(("/bin/rm") "rm"))
(setenv "CC" "gcc")
@@ -366,9 +370,13 @@ statistical profiler, a code coverage tool, and many other extensions.")
(bash (assoc-ref inputs "bash"))
(kernel
,(match (or (%current-target-system) (%current-system))
- ("i686-linux" "lx86cl")
+ ("i686-linux" "lx86cl")
("x86_64-linux" "lx86cl64")
- ("armhf-linux" "armcl")))
+ ("armhf-linux" "armcl")
+ ;; Prevent errors when querying this package
+ ;; on unsupported platforms, e.g. when running
+ ;; "guix package --search="
+ (_ "UNSUPPORTED")))
(heap (string-append kernel ".image")))
(mkdir-p libdir)
(mkdir-p bindir)