summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-03-03 09:40:34 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-03 09:52:52 +0100
commita359b744ce1b3385c4616e15b3f6b945a1ae3f7f (patch)
tree5b088c225c64780912e52142b9e64549b8fc3936 /gnu/packages/lisp.scm
parentd5e41d71661d0d76c6a890af385322c83949d35f (diff)
gnu: eisl: Update to 2.72.
* gnu/packages/lisp.scm (eisl): Update to 2.72. [arguments]: Update 'fix-paths' phase.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index ccb7b68d06..67ba04c3ff 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -1428,7 +1428,7 @@ executable Common Lisp image. It is similar to cl-launch and hu.dwim.build.")
(define-public eisl
(package
(name "eisl")
- (version "2.65")
+ (version "2.72")
(source
(origin
(method git-fetch)
@@ -1437,7 +1437,7 @@ executable Common Lisp image. It is similar to cl-launch and hu.dwim.build.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1cnis1v70k4wmvw1gmvj3l9qajzncaa9ka8rx67vx12bgrr0811g"))))
+ (base32 "12dc6b70dcfalyq3h5i7lmz39xh310k5p83x5q6j18knd6ql9ik9"))))
(build-system gnu-build-system)
(inputs
(list bash-minimal freeglut gdbm libiconv ncurses tcl tk))
@@ -1455,8 +1455,8 @@ executable Common Lisp image. It is similar to cl-launch and hu.dwim.build.")
(("\"cc ")
"\"gcc "))
(substitute* "library/tcltk.lsp"
- (("c-include \"<tcl/tcl\\.h>\"")
- "c-include \"<tcl.h>\"")
+ (("include <tcl/tcl\\.h>")
+ "include <tcl.h>")
(("c-option \"-ltcl -ltk\" linux")
"c-option \"-ltcl8.6 -ltk8.6\" linux"))))
(delete 'configure)