summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorAndrew Patterson <andrewpatt7@gmail.com>2022-11-17 21:53:01 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2022-11-19 12:58:12 +0100
commitcc08d374b21f1326c2d70d5af84b56c0714a0885 (patch)
tree1fb476ab5763e1daba5b6cba8c3a8f80ed2f7ff6 /gnu/packages/lisp.scm
parent854bdb7ba9abd6392da823f723553df03077e9a7 (diff)
gnu: sbcl: Fix build on aarch64.
sbcl 2.2.10 currently doesn't build on aarch64. Upstream has fixed the issue (https://bugs.launchpad.net/sbcl/+bug/1996942), but this patch is needed until the next release. * gnu/packages/patches/sbcl-fix-build-on-arm64-with-clisp-as-host.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/lisp.scm (sbcl)[source]: Use it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 80018f8e1a..0749a02cd7 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -429,6 +429,9 @@ an interpreter, a compiler, a debugger, and much more.")
(method url-fetch)
(uri (string-append "mirror://sourceforge/sbcl/sbcl/" version "/sbcl-"
version "-source.tar.bz2"))
+ (patches
+ ;; TODO: remove this patch when updating to sbcl > 2.2.10.
+ (search-patches "sbcl-fix-build-on-arm64-with-clisp-as-host.patch"))
(sha256
(base32 "0cq8x4svkawirxq5s5gs4qxkl23m4q5p722a2kpss8qjfslc7hwc"))))
(build-system gnu-build-system)