summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2024-01-17 17:36:55 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-10 15:06:50 +0000
commit354de73fa45bdf045ccca8461dab500f5347b06c (patch)
tree06c1a02b11c601c6bcdb01b7f2998bf0d0545779 /gnu/packages/llvm.scm
parent6a59d3ad68b1b5cab062115fdfbccacdb64669f1 (diff)
gnu: lldb: Update to 17.0.6.
* gnu/packages/llvm.scm (lldb): Update to 17.0.6. [inputs]: Change from LLVM-15 and CLANG-15 to LLVM-17 and CLANG-17. Change-Id: Iad04ee722c81ecb223ea4d57d25ea57ca7df59a0 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 0062bc56cd..2778d0ec38 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
;;; Copyright © 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2022, 2024 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
@@ -1709,7 +1709,7 @@ misuse of libraries outside of the store.")))
(define-public lldb
(package
(name "lldb")
- (version (package-version llvm-15))
+ (version (package-version llvm-17))
(source (llvm-monorepo version))
(build-system cmake-build-system)
(arguments
@@ -1723,8 +1723,8 @@ misuse of libraries outside of the store.")))
(native-inputs
(list pkg-config swig))
(inputs
- (list clang-15
- llvm-15
+ (list clang-17
+ llvm-17
;; Optional (but recommended) inputs.
ncurses
libedit