summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-06-29 18:09:15 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-07-03 01:26:17 +0200
commit5ce123bd9a1597bdbb8c1a83fb73ae82a0b86f60 (patch)
treec09955650f53d6a827e56baea827a46c8b61de9c /gnu/packages/llvm.scm
parentff2f86114c0d250351661a81bb95c627141179d8 (diff)
gnu: Add lld.
* gnu/packages/llvm.scm (lld): New variable.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 1a8c69639e..7cd9543036 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -538,6 +538,30 @@ output), and Binutils.")
(define-public clang clang-9)
(define-public clang-toolchain clang-toolchain-9)
+(define-public lld
+ (package
+ (name "lld")
+ (version (package-version llvm-10))
+ (source (origin
+ (method url-fetch)
+ (uri (llvm-download-uri "lld" version))
+ (sha256
+ (base32
+ "026pwcbczcg0j5c9h7hxxrn3ki81ia9m9sfn0sy0bvzffv2xg85r"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("llvm" ,llvm-10)))
+ (arguments
+ `(#:build-type "Release"
+ ;; TODO: Tests require the lit tool, which isn't installed by the LLVM
+ ;; package.
+ #:tests? #f))
+ (home-page "https://lld.llvm.org/")
+ (synopsis "Linker from the LLVM project")
+ (description "LLD is a high-performance linker, built as a set of reusable
+components which highly leverage existing libraries in the larger LLVM Project.")
+ (license license:asl2.0))) ; With LLVM exception
+
(define-public llvm-8
(package
(inherit llvm)