summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-22 21:42:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-22 21:45:29 -0400
commitcb2e7efa6c17f02c7051bcf6e0d1b8b869ebcce7 (patch)
tree17d753a77d37e11bfb4a0f2008a95a102a69ed94 /gnu/packages/llvm.scm
parentb58bac0086a58ea00fd4e2f94e552bab7ebc9b8b (diff)
gnu: cling: Correct erroneous substitute pattern.
* gnu/packages/llvm.scm (cling) [arguments]: Properly escape '\b' in the regexp pattern of the patch-paths phase.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 09c546734e..e5bf9f5cae 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -2257,7 +2257,7 @@ LLVM."))))
(add-after 'unpack 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "lib/Interpreter/CIFactory.cpp"
- (("\bsed\b")
+ (("\\bsed\\b")
(which "sed"))
;; This ensures that the default C++ library used by Cling is
;; that of the compiler that was used to build it, rather