summaryrefslogtreecommitdiff
path: root/gnu/packages/lsh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-02-23 18:20:47 +0100
committerLudovic Courtès <ludo@gnu.org>2016-02-24 13:11:50 +0100
commit03b93ed70e8904f583f092e65f174690f20bf5bf (patch)
treea4fd783239e20eeacb21f01cb0c58998ac1b5fcf /gnu/packages/lsh.scm
parentea84bd88da2212bdaa905ce4bbd3d4ac1b5272bc (diff)
gnu: lsh: Use 'modify-phases'.
* gnu/packages/lsh.scm (lsh)[arguments]: Use 'modify-phases' instead of 'alist-cons-before'.
Diffstat (limited to 'gnu/packages/lsh.scm')
-rw-r--r--gnu/packages/lsh.scm37
1 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/lsh.scm b/gnu/packages/lsh.scm
index e034d66940..90631e3fe5 100644
--- a/gnu/packages/lsh.scm
+++ b/gnu/packages/lsh.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -113,26 +113,25 @@ basis for almost any application.")
#:tests? #f
#:phases
- (alist-cons-before
- 'configure 'pre-configure
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((nettle (assoc-ref inputs "nettle"))
- (sexp-conv (string-append nettle "/bin/sexp-conv")))
- ;; Make sure 'lsh' and 'lshd' pick 'sexp-conv' in the right place
- ;; by default.
- (substitute* "src/environ.h.in"
- (("^#define PATH_SEXP_CONV.*")
- (string-append "#define PATH_SEXP_CONV \""
- sexp-conv "\"\n")))
+ (modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((nettle (assoc-ref inputs "nettle"))
+ (sexp-conv (string-append nettle "/bin/sexp-conv")))
+ ;; Make sure 'lsh' and 'lshd' pick 'sexp-conv' in the right place
+ ;; by default.
+ (substitute* "src/environ.h.in"
+ (("^#define PATH_SEXP_CONV.*")
+ (string-append "#define PATH_SEXP_CONV \""
+ sexp-conv "\"\n")))
- ;; Same for the 'lsh-authorize' script.
- (substitute* "src/lsh-authorize"
- (("=sexp-conv")
- (string-append "=" sexp-conv))))
+ ;; Same for the 'lsh-authorize' script.
+ (substitute* "src/lsh-authorize"
+ (("=sexp-conv")
+ (string-append "=" sexp-conv))))
- ;; Tests rely on $USER being set.
- (setenv "USER" "guix"))
- %standard-phases)))
+ ;; Tests rely on $USER being set.
+ (setenv "USER" "guix"))))))
(home-page "http://www.lysator.liu.se/~nisse/lsh/")
(synopsis "GNU implementation of the Secure Shell (ssh) protocols")
(description