summaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
authorBrian Kubisiak <brian@kubisiak.com>2022-03-28 18:37:28 -0700
committerMathieu Othacehe <othacehe@gnu.org>2022-03-30 11:50:58 +0200
commita006b7d34757dbafc0d71d875613e6df521efe51 (patch)
tree1192c9d949b91e9a629852ec8818d06fa9506c31 /gnu/packages/lsof.scm
parent457999ce36470ed7e8626e41dfdd236cfcaf8060 (diff)
gnu: lsof: Fix cross-compilation.
* gnu/packages/lsof (lsof)[arguments]: Add LINUX_CONF_CC environment variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index 98bcdab468..f872eb8de8 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -54,6 +54,7 @@
(replace 'configure
(lambda _
(setenv "LSOF_CC" ,(cc-for-target))
+ (setenv "LINUX_CONF_CC" "gcc")
(setenv "LSOF_MAKE" "make")
;; By default, the makefile captures the output of 'uname -a'.