summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-18 01:09:25 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-18 01:09:25 +0100
commit7ace97395feedc4b3ec23be65f2ed63f29aac9a9 (patch)
tree768956fa30fc7b21e4e4715eafbb10dab32b2847 /gnu/packages/lua.scm
parenta248a9ac6a67213b177ab5ba9ec270638c9dd002 (diff)
parentbe5ed142135e939cd23fcfe88c553fd28b32ac53 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 0d4bf12817..69180abeac 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -354,12 +354,12 @@ secure session between the peers.")
(inputs
`(("gobject-introspection" ,gobject-introspection)
("glib" ,glib)
- ("pango", pango)
- ("gtk", gtk+-2)
+ ("pango" ,pango)
+ ("gtk" ,gtk+-2)
("lua" ,lua)
("cairo" ,cairo)
("libffi" ,libffi)
- ("xorg-server", xorg-server)))
+ ("xorg-server" ,xorg-server)))
(native-inputs
`(("pkg-config" ,pkg-config)
("dbus" ,dbus))) ;tests use 'dbus-run-session'
@@ -397,7 +397,7 @@ Notable examples are GTK+, GStreamer and Webkit.")
(string-append out "/share/lua/" lua-version))
#t))))
#:test-target "test"))
- (inputs `(("lua", lua)))
+ (inputs `(("lua" ,lua)))
(synopsis "Pattern-matching library for Lua")
(description
"LPeg is a pattern-matching library for Lua, based on Parsing Expression
@@ -436,7 +436,7 @@ Grammars (PEGs).")
#:phases
(modify-phases %standard-phases
(delete 'configure))))
- (inputs `(("lua", lua)))
+ (inputs `(("lua" ,lua)))
(home-page "https://bitop.luajit.org/index.html")
(synopsis "Bitwise operations on numbers for Lua")
(description