summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2022-08-17 11:07:44 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-08-22 08:42:54 +0800
commitda546ff3b911157c13e07246027a4fcffbd66cc5 (patch)
treeef5448845b4462e4c35921bf5018477417de2522 /gnu/packages/lxqt.scm
parent64678c72280c6d627d4b2a9fc62855b2680e5cc4 (diff)
gnu: lxqt-sudo: Update to 1.1.0.
* gnu/packages/lxqt.scm (lxqt-sudo): Update to 1.1.0. [arguments]: Remove phases.
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 9fea479605..5b3625bd08 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -756,14 +756,14 @@ for the LXQt desktop environment.")
(define-public lxqt-sudo
(package
(name "lxqt-sudo")
- (version "0.17.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "02s38m0ywp0gjkjczvrc4r1ignshbajlj084xd61d3rcm7vahhic"))))
+ (base32 "064w40v43m91y9aywxxf2pj5rpcl4gbsgj7dv97pg4vhj9s790b8"))))
(build-system cmake-build-system)
(inputs
(list kwindowsystem
@@ -775,17 +775,7 @@ for the LXQt desktop environment.")
sudo))
(native-inputs
(list pkg-config qttools-5 lxqt-build-tools))
- (arguments
- '(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-translations-dir
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "CMakeLists.txt"
- (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
- (string-append (assoc-ref outputs "out")
- "/share/lxqt/translations")))
- #t)))))
+ (arguments '(#:tests? #f)) ; no tests
(home-page "https://lxqt-project.org")
(synopsis "GUI frontend for sudo/su")
(description "lxqt-sudo is a graphical front-end of commands sudo and su