summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2022-08-17 10:31:34 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-08-22 08:42:54 +0800
commitfddf8dfa4e4f914f2d7d58b6eb7699cb99bc13bd (patch)
treeca7bccde8a9c9e3a5b0835ea76cda45a26259bad /gnu/packages/lxqt.scm
parent826f188d52aa924e09b6480be334003a48742554 (diff)
gnu: lxqt-openssh-askpass: Update to 1.1.0.
* gnu/packages/lxqt.scm (lxqt-openssh-askpass): Update to 1.1.0. [arguments]: Remove phases.
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index c2f1c054e1..dc0c7b9e44 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -481,14 +481,14 @@ according to the Desktop Notifications Specification.")
(define-public lxqt-openssh-askpass
(package
(name "lxqt-openssh-askpass")
- (version "0.17.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0gdcy8c21sbfrlfz9c3zqw4dvdwf309flkjgqanwwl9i8hr26chr"))))
+ (base32 "1hxix513z2sanmygfzq1fgx30kaxw5rjmmklbyyzl8bv1xzjcwk7"))))
(build-system cmake-build-system)
(inputs
(list kwindowsystem
@@ -499,17 +499,7 @@ according to the Desktop Notifications Specification.")
qtx11extras))
(native-inputs
(list lxqt-build-tools qttools-5))
- (arguments
- '(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-translations-dir
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "CMakeLists.txt"
- (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
- (string-append (assoc-ref outputs "out")
- "/share/lxqt/translations")))
- #t)))))
+ (arguments '(#:tests? #f)) ; no tests
(home-page "https://lxqt-project.org")
(synopsis "GUI to query passwords on behalf of SSH agents")
(description "lxqt-openssh-askpass is a GUI to query credentials on behalf