summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2022-08-17 11:09:43 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-08-22 08:42:54 +0800
commit50fb051d9760b484f6edea02cec61c78655e0c25 (patch)
tree6247dad6ef5675e738cc26c5b2c02eb56c381e31 /gnu/packages/lxqt.scm
parent892d8995de139e279a8199f18793dc547e6e3b9b (diff)
gnu: pcmanfm-qt: Update to 1.1.0.
* gnu/packages/lxqt.scm (pcmanfm-qt) [version]: Update to 1.1.0. [inputs]: Add lxqt-themes. [arguments]: Remove patch-source phase. Add patch-settings.conf.in phase.
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm31
1 files changed, 15 insertions, 16 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 08e33ca0e3..d2cbd1e131 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -843,32 +843,31 @@ components to build desktop file managers which belongs to LXDE.")
(define-public pcmanfm-qt
(package
(name "pcmanfm-qt")
- (version "0.17.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1axs7dnh2z08ygy28iipfbgfck15k2i2pwlf0v8d8axjrmavzb3l"))))
+ (base32 "0pwl2j5kbs86vmq86phavq89bl2i82ic839bjk0v8kmxm9q2mrh9"))))
(build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'patch-settings.conf.in
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((wallpaper (search-input-file inputs
+ "share/lxqt/wallpapers/waves-logo.png")))
+ (substitute* "config/pcmanfm-qt/lxqt/settings.conf.in"
+ (("Wallpaper=.*")
+ (string-append "Wallpaper=" wallpaper "\n")))))))))
(inputs
- (list libfm-qt qtbase-5 qtx11extras))
+ (list libfm-qt qtbase-5 qtx11extras lxqt-themes))
(native-inputs
(list pkg-config qttools-5 lxqt-build-tools))
- (arguments
- '(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-source
- (lambda _
- (substitute* '("autostart/CMakeLists.txt")
- (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
- "DESTINATION \"etc/xdg"))
- (substitute* '("config/pcmanfm-qt/lxqt/settings.conf.in")
- (("@LXQT_SHARE_DIR@")
- "/run/current-system/profile/share/lxqt" ))
- #t)))))
(home-page "https://lxqt-project.org")
(synopsis "File manager and desktop icon manager")
(description "PCManFM-Qt is the Qt port of PCManFM, the file manager of