summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-09 12:26:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:35 +0100
commitc085139bc99751e930cb0128aa804ab3e4a5cf6a (patch)
treeab4a8177e2f7a24bf057bd7af1286fca74fc053f /gnu/packages/machine-learning.scm
parentefd98a9c450c7783c45214d03e65ac409ae9864c (diff)
gnu: python-captum: Update to 0.7.0.
* gnu/packages/machine-learning.scm (python-captum): Update to 0.7.0. [propagated-inputs]: Add python-tqdm. Change-Id: I8917b6e294fe08077a3af4423deefa9769ba9384
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 7bf8cdb894..1540018347 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -4199,7 +4199,7 @@ Actions for the Lightning suite of libraries.")
(define-public python-captum
(package
(name "python-captum")
- (version "0.6.0")
+ (version "0.7.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4208,7 +4208,7 @@ Actions for the Lightning suite of libraries.")
(file-name (git-file-name name version))
(sha256
(base32
- "1h4n91ivhjxm6wj0vgqpfss2dmq4sjcp0appd08cd5naisabjyb5"))))
+ "0bgfwnlsi50hbmknn7qljiy93fi6ggwz3k7yk9kj7s37mhzaylym"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -4218,7 +4218,8 @@ Actions for the Lightning suite of libraries.")
;; accuracy problems.
"not test_softmax_classification_batch_multi_target\
and not test_softmax_classification_batch_zero_baseline")))
- (propagated-inputs (list python-matplotlib python-numpy python-pytorch))
+ (propagated-inputs
+ (list python-matplotlib python-numpy python-pytorch python-tqdm))
(native-inputs (list jupyter
python-annoy
python-black