summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-03 11:54:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:18 +0200
commitc226d12856bffbf0ba233be087dd4a0b6f9bfc4d (patch)
treef7ec297d09afa4a63317d014477f9a88dc0d30c9 /gnu/packages/machine-learning.scm
parent1ea0e3e6dd9cc9013072f5d4bb0675c201aa8d57 (diff)
gnu: python-scikit-learn-extra: Disable a validation test.
* gnu/packages/machine-learning.scm (python-scikit-learn-extra)[arguments]: Disable one test. Change-Id: I1309cb6a82dee1a714ddec59aa90692ccfcd885b
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm42
1 files changed, 23 insertions, 19 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 39b3a36b65..7ff8c098b1 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1762,26 +1762,30 @@ data analysis.")
#:test-flags
;; ignore tests that require network
'(list "--pyargs" "sklearn_extra"
- "-k" "not test_build")
+ "-k" (string-append "not test_build"
+ ;; The error message format has changed,
+ ;; but the behavior itself is still the
+ ;; same.
+ " and not test_parameter_validation"))
#:phases
- #~(modify-phases %standard-phases
- (add-after 'build 'build-ext
- (lambda _
- (invoke "python" "setup.py" "build_ext"
- "--inplace")))
- (replace 'check
- (lambda* (#:key tests? test-flags #:allow-other-keys)
- (when tests?
- ;; Restrict OpenBLAS threads to prevent segfaults while testing!
- (setenv "OPENBLAS_NUM_THREADS" "1")
-
- ;; Some tests require write access to $HOME.
- (setenv "HOME" "/tmp")
-
- ;; Step out of the source directory to avoid interference;
- ;; we want to run the installed code with extensions etc.
- (with-directory-excursion "/tmp"
- (apply invoke "pytest" "-vv" test-flags))))))))
+ #~(modify-phases %standard-phases
+ (add-after 'build 'build-ext
+ (lambda _
+ (invoke "python" "setup.py" "build_ext"
+ "--inplace")))
+ (replace 'check
+ (lambda* (#:key tests? test-flags #:allow-other-keys)
+ (when tests?
+ ;; Restrict OpenBLAS threads to prevent segfaults while testing!
+ (setenv "OPENBLAS_NUM_THREADS" "1")
+
+ ;; Some tests require write access to $HOME.
+ (setenv "HOME" "/tmp")
+
+ ;; Step out of the source directory to avoid interference;
+ ;; we want to run the installed code with extensions etc.
+ (with-directory-excursion "/tmp"
+ (apply invoke "pytest" "-vv" test-flags))))))))
(propagated-inputs
(list python-numpy
python-scikit-learn