summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-03-11 12:06:48 +0100
committerLudovic Courtès <ludo@gnu.org>2024-04-04 16:17:20 +0200
commitd400d88eb6df12093cf08b7a352c9dd8aad1e650 (patch)
treee7beccc438a146382661e5d94d849e97cfecf1a4 /gnu/packages/machine-learning.scm
parent6481610da9359ce1751ec6913e2b7d02eb727693 (diff)
gnu: vosk-api: Remove dependency on lapack.
* gnu/packages/machine-learning.scm (vosk-api): Remove input dependency on lapack. Change-Id: Id46b37f06bffde5f8a198c1ac913a3dff8ce63e6 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 23791dfd03..6e2affb2eb 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -5160,8 +5160,7 @@ linear algebra routines needed for structured matrices (or operators).")
(lambda _ (chdir "src")))
(replace 'configure
(lambda _
- (let* ((lapack #$(this-package-input "lapack"))
- (openfst #$(this-package-input "openfst"))
+ (let* ((openfst #$(this-package-input "openfst"))
(openblas #$(this-package-input "openblas"))
(kaldi #$(this-package-input "kaldi")))
(substitute* "./Makefile"
@@ -5171,8 +5170,7 @@ linear algebra routines needed for structured matrices (or operators).")
"")
(("-lopenblas -llapack -lblas -lf2c")
(string-append
- "-L" openblas "/lib " "-lopenblas "
- "-L" lapack "/lib " "-llapack -lblas "))
+ "-L" openblas "/lib " "-lopenblas "))
(("-lfst -lfstngram")
(string-append
"-L" openfst "/lib " "-lfst -lfstngram "))
@@ -5194,7 +5192,7 @@ linear algebra routines needed for structured matrices (or operators).")
(for-each
(lambda (x) (install-file x src))
(find-files "." "\\.h$"))))))))
- (inputs (list kaldi openfst lapack openblas))
+ (inputs (list kaldi openfst openblas))
(home-page "https://alphacephei.com/vosk")
(synopsis "Speech recognition toolkit based on @code{kaldi}")
(description "\