summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-08 13:19:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:34 +0100
commit247c427302daebf59a23b18d24a6bb0e9bbd906e (patch)
treec8f81f7cc1a9f93ccdcbd8b2a1ebd163ba9fb958 /gnu/packages/machine-learning.scm
parente759380796589e20bf1a4ed18ee9632430932464 (diff)
gnu: python-scikit-learn: Update to 1.3.2.
* gnu/packages/machine-learning.scm (python-scikit-learn): Update to 1.3.2. [build-system]: Use pyproject-build-system. [arguments]: Move test flags to #:test-flags. [native-inputs]: Replace python-cython with python-cython-0.29.35. Change-Id: Iac6107dae752c42d9f57448a66eed0526974d57e
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm28
1 files changed, 15 insertions, 13 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 9e65084f34..af55a99152 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1613,7 +1613,7 @@ computing environments.")
(define-public python-scikit-learn
(package
(name "python-scikit-learn")
- (version "1.2.2")
+ (version "1.3.2")
(source
(origin
(method git-fetch)
@@ -1623,20 +1623,25 @@ computing environments.")
(file-name (git-file-name name version))
(sha256
(base32
- "0x7gfzvcdadf8jnvpz8m373bi37bc6sndfbjh9lzmn3p39pwm2hl"))))
- (build-system python-build-system)
+ "1hr024vcilbjwlwn32ppadri0ypnzjmkfxhkkw8gih0qjvcvjbs7"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
+ (list
+ #:test-flags
+ '(list "-m" "not network"
+ ;; This test tries to access the internet.
+ "-k" "not test_load_boston_alternative")
+ #:phases
+ '(modify-phases %standard-phases
(add-before 'build 'configure
(lambda _
(setenv "SKLEARN_BUILD_PARALLEL"
(number->string (parallel-job-count)))))
(add-after 'build 'build-ext
(lambda _ (invoke "python" "setup.py" "build_ext" "--inplace"
- "-j" (number->string (parallel-job-count)))))
+ "-j" (number->string (parallel-job-count)))))
(replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
+ (lambda* (#:key tests? test-flags #:allow-other-keys)
(when tests?
;; Restrict OpenBLAS threads to prevent segfaults while testing!
(setenv "OPENBLAS_NUM_THREADS" "1")
@@ -1647,14 +1652,11 @@ computing environments.")
;; Step out of the source directory to avoid interference;
;; we want to run the installed code with extensions etc.
(with-directory-excursion "/tmp"
- (invoke "pytest" "-vv" "--pyargs" "sklearn"
- "-m" "not network"
- "-n" (number->string (parallel-job-count))
- ;; This test tries to access the internet.
- "-k" "not test_load_boston_alternative"))))))))
+ (apply invoke "pytest" "--pyargs" "sklearn"
+ test-flags))))))))
(inputs (list openblas))
(native-inputs
- (list python-cython
+ (list python-cython-0.29.35
python-pandas
python-pytest
python-pytest-xdist))