summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-04-27 20:33:38 -0300
committerVinicius Monego <monego@posteo.net>2023-05-14 11:10:24 -0300
commitc5ebf6ff974057daa3e078f806df9a151440fecd (patch)
tree406d75e5fc8f28a4838ebb95c0028eb308032bd0 /gnu/packages/machine-learning.scm
parent52c9400724a2a42cd9a1b19567bdabe7029f8a87 (diff)
gnu: python-cmaes: Update to 0.9.1.
* gnu/packages/machine-learning.scm (python-cmaes): Update to 0.9.1. [source, home-page]: Follow redirect. [build-system]: Switch to pyproject-build-system. [native-inputs]: Remove python-setuptools, python-wheel.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index b8793fb31a..269bfd4459 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1520,23 +1520,20 @@ and a few related numerical optimization tools.")
(define-public python-cmaes
(package
(name "python-cmaes")
- (version "0.8.2")
+ (version "0.9.1")
(source
(origin
(method git-fetch) ;no tests in PyPI
(uri (git-reference
- (url "https://github.com/CyberAgent/cmaes")
+ (url "https://github.com/CyberAgentAILab/cmaes")
(commit (string-append "v" version))))
(sha256
- (base32 "1jyckaifir528dz6m95nvky8hvqmz5gz6dlp65baahhbca0danzb"))
+ (base32 "1f3143w8ii6i93bdh65iazrq1lryccd805ndnqww5l8h7qnnzpkm"))
(file-name (git-file-name name version))))
- (build-system python-build-system)
- (native-inputs
- (list python-setuptools ;build fails without this
- python-wheel))
- (propagated-inputs
- (list python-numpy))
- (home-page "https://github.com/CyberAgent/cmaes")
+ (build-system pyproject-build-system)
+ (native-inputs (list python-hypothesis))
+ (propagated-inputs (list python-numpy))
+ (home-page "https://github.com/CyberAgentAILab/cmaes")
(synopsis "CMA-ES implementation for Python")
(description "This package provides provides an implementation of the
Covariance Matrix Adaptation Evolution Strategy (CMA-ES) for Python.")